Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - ZJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 04-29-2011, 05:03 AM
BLACK DOG's Avatar
Premium Member
My Jeep: 2007 5.7L WK
 
Join Date: Jul 2010
Location: BC., Canada
Posts: 439
Thanks: 21
Thanked 0 Times in 0 Posts
Rep Power: 1986
BLACK DOG has a reputation beyond reputeBLACK DOG has a reputation beyond repute
Strange Electrical Gremlins

I have been having some weird elect. problems with a couple of my ZJs , the blower fan keeps running with ign. off, intermittent on 1 5,2 and always on my 5.9 ( I have to pull the fuse to stop it )
I also see the 4wheel indicator shows 2 rear or 2 front or all 4 at different times restart the car and it may change haven't noticed it change without restart, could this be just dirty connections ??
not looking forward to pulling the dashes apart, any answers similar problems brothers and sisters, it's keeping me up late
__________________

__________________
That's the WRONG side of this fence Bub, and these ain't Halos.. Daddy don't like nobodyz in here with his jeeps!!! Let's play chase yer balls, you gotz any balls, do ya?

07 WK LTD 5.7, with 13000 klm (7600 miles)So Far... repaint and debage, probly shoulda just got the SRT in the begining...now Im gonna hafta go expensive exotic aftermarket to be Blissfully Demented. SRT Nose and Stillens shiney new shoes SRT springs, Front/Rear Sways, WK HD Bilsteins, a couple of plastic bits from JforJ, all ready to go on. SRT Headers and mid pipes with cats waiting for the new predator inTune ( it'll match my new iPhone...Wait maybe its a iPhone app ) SRT coil covers & roof rails another problem to be solved
Reply With Quote
  #2  
Old 05-29-2011, 02:25 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,829
Thanks: 9
Thanked 77 Times in 72 Posts
Rep Power: 525764
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Strange Electrical Gremlins

He Bob, did you find the problem? Did it had to do with the ignition switch?
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 05-29-2011, 04:19 PM
BLACK DOG's Avatar
Premium Member
My Jeep: 2007 5.7L WK
 
Join Date: Jul 2010
Location: BC., Canada
Posts: 439
Thanks: 21
Thanked 0 Times in 0 Posts
Rep Power: 1986
BLACK DOG has a reputation beyond reputeBLACK DOG has a reputation beyond repute
Re: Strange Electrical Gremlins

No Frank, problems not corrected, I haven't had time to get to it...I'm convinced the problem is dirt/dust in the connections, I'm having similar problems with bulbs not lighting, I check the bulb, it looks ok I plug it back in and it works fine. There is a lot of dust in my area and dampness too. I have been doing mods on the 5.7 WK and training my dog. Just not finding any time (always something more important to do) Bob.
__________________
That's the WRONG side of this fence Bub, and these ain't Halos.. Daddy don't like nobodyz in here with his jeeps!!! Let's play chase yer balls, you gotz any balls, do ya?

07 WK LTD 5.7, with 13000 klm (7600 miles)So Far... repaint and debage, probly shoulda just got the SRT in the begining...now Im gonna hafta go expensive exotic aftermarket to be Blissfully Demented. SRT Nose and Stillens shiney new shoes SRT springs, Front/Rear Sways, WK HD Bilsteins, a couple of plastic bits from JforJ, all ready to go on. SRT Headers and mid pipes with cats waiting for the new predator inTune ( it'll match my new iPhone...Wait maybe its a iPhone app ) SRT coil covers & roof rails another problem to be solved
Reply With Quote
  #4  
Old 06-02-2011, 07:50 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,829
Thanks: 9
Thanked 77 Times in 72 Posts
Rep Power: 525764
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Strange Electrical Gremlins

Dust normally shouldn´t do much harm, most of the time the problem is moisture which causes the contacts to oxydice and create a certain resistance. But in your case with the fan the problem is probably different, you have power when youre not suppost to have it. I think that only the ignition switch is there to cut the power to the blower fan.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
The Following User Says Thank You to Frango100 For This Useful Post:
  #5  
Old 06-02-2011, 10:24 AM
BLACK DOG's Avatar
Premium Member
My Jeep: 2007 5.7L WK
 
Join Date: Jul 2010
Location: BC., Canada
Posts: 439
Thanks: 21
Thanked 0 Times in 0 Posts
Rep Power: 1986
BLACK DOG has a reputation beyond reputeBLACK DOG has a reputation beyond repute
Re: Strange Electrical Gremlins

the ign. switch could be the problem, another thing is both jeeps I'm having this issue with have other things added to the system that could be contributing to the problem, (aftermarket alarm on one and a stereo on the other, both have bypassed ignition and have power with ign. switch off) I'm not very good with solving elect. problems unless it is an obvious problem like a broken wire, I start swapping parts / switches to find the problem...ign. switch seems like a good place to start. Looking to see if extra wires were tapped into it for example. Both Fans also stay running even with the heater switch in the off position.
__________________
Reply With Quote
  #6  
Old 06-02-2011, 08:04 PM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,829
Thanks: 9
Thanked 77 Times in 72 Posts
Rep Power: 525764
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Strange Electrical Gremlins

If you have an electrical schematic, you could see which wire from the ignition switch is going to the blower motor. Then you could measure for voltage with the switch in off. I think its better to troubleshoot this first before trowing parts to it in the hope to solve it.
I won´t expect a radio or alarm bypass wire would cause this problem, because they normally have a low Amp fuse in line and that one would probably blow by the high blower current. You also said that pulling the blower motor fuse will stop it, so its then almost certain that the problem is in the blower motor circuit itself, or better, the ignition switch is not cutting the power.
__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #7  
Old 06-03-2011, 05:14 AM
BLACK DOG's Avatar
Premium Member
My Jeep: 2007 5.7L WK
 
Join Date: Jul 2010
Location: BC., Canada
Posts: 439
Thanks: 21
Thanked 0 Times in 0 Posts
Rep Power: 1986
BLACK DOG has a reputation beyond reputeBLACK DOG has a reputation beyond repute
Re: Strange Electrical Gremlins

I will check out the ign. switch, I have a schematic and meter. Hopefully it will save me from having to remove the heater control, the niner has a stereo poorly installed (loose wires etc.) Powered direct to the Bat. possibly draining the battery as well.Though not as much of a drain as the blower fan. ( the niner has the 40 amp fuse removed)
__________________

__________________
That's the WRONG side of this fence Bub, and these ain't Halos.. Daddy don't like nobodyz in here with his jeeps!!! Let's play chase yer balls, you gotz any balls, do ya?

07 WK LTD 5.7, with 13000 klm (7600 miles)So Far... repaint and debage, probly shoulda just got the SRT in the begining...now Im gonna hafta go expensive exotic aftermarket to be Blissfully Demented. SRT Nose and Stillens shiney new shoes SRT springs, Front/Rear Sways, WK HD Bilsteins, a couple of plastic bits from JforJ, all ready to go on. SRT Headers and mid pipes with cats waiting for the new predator inTune ( it'll match my new iPhone...Wait maybe its a iPhone app ) SRT coil covers & roof rails another problem to be solved
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
430N Navigation Is Strange Remleym Audio/Visual/Navigation 11 09-08-2011 09:44 PM
Strange whine when accelerating dudedrt Grand Cherokee - WK 7 02-22-2011 09:56 AM
Strange Vibration, need help sodeljeepster Wrangler-YJ, TJ & JK 6 02-09-2011 01:07 AM
having some strange issues chefalan23 Grand Cherokee - WK 15 09-19-2009 12:19 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:53 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community