Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee - ZJ

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 03-12-2010, 02:00 AM
hemi.jon's Avatar
Member
 
Join Date: May 2009
Posts: 802
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2799
hemi.jon has a reputation beyond reputehemi.jon has a reputation beyond reputehemi.jon has a reputation beyond repute
Re: ZJ Not starting...???

well in the wranglers the pump is in the tank, so if you have the same I6 it probably is to.
a good way to check is have a buddy lay under the jeep by the tank, turn the jeep to the 'on' position but do not start it, you should hear the pump prime. if it wont prime then its the pump.

Another way to test it is to hit the bottom of the tank where the pump is located (lowest dip in the tank) on almost every vehicle if you hit that spot with a rubber mallet once or twice the vehicle will sometimes crank right up. (very very temp fix)
__________________

__________________
Reply With Quote
  #14  
Old 03-12-2010, 02:46 AM
Member
 
Join Date: Feb 2010
Location: South Africa
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1705
Navigtor is on a distinguished road
Re: ZJ Not starting...???

Thanks for the reply, will check tonight - but there is no sound from the Fuel Pump.... nothing... as if there is no power! If the pump is faulty, surely it with make some kind of noise?
__________________

__________________
Reply With Quote
  #15  
Old 03-12-2010, 08:35 AM
1 GRAND's Avatar
Member
 
Join Date: Jul 2009
Location: Elkhorn City, Kentucky
Posts: 748
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2677
1 GRAND has a reputation beyond repute1 GRAND has a reputation beyond repute
Re: ZJ Not starting...???

Pump is inside the tank. Sits in the top.
You have to drop the tank to get it out.
__________________


2007 Jeep Grand Cherokee Overland Hemi QD II

2006 Jeep Commander 65th Anniversary 3.7 4x4

1998 Jeep Grand Cherokee 5.9 Limited 4x4

1994 Jeep Grand Cherokee Limited V8 4x4 Lifted
Reply With Quote
  #16  
Old 03-12-2010, 03:07 PM
hemi.jon's Avatar
Member
 
Join Date: May 2009
Posts: 802
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2799
hemi.jon has a reputation beyond reputehemi.jon has a reputation beyond reputehemi.jon has a reputation beyond repute
Re: ZJ Not starting...???

my exp with the jeep pumps is when they go faulty they are either off or on, no real in between. so if its not priming it is a common jeep problem for them to crap out
__________________
Reply With Quote
  #17  
Old 03-12-2010, 04:03 PM
Denny boy's Avatar
Member
 
Join Date: Jun 2009
Location: Shoreview, MN
Posts: 605
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 2555
Denny boy is a jewel in the rough
Re: ZJ Not starting...???

yah it's teh fuel pump, or could be the pwer wire going to it check teh wire mine just cranked and it wouldnt turn the pump on cuz i broke teh wire wheeling.
__________________
Dakota County Technical College
Entry level GM Tech
Cataclysmic Perverter
Searching for a new jeep to me, gotta get back in the jeep game.
If you don't stand behind our troops, PLEASE feel free to stand in front of them.
Reply With Quote
  #18  
Old 03-15-2010, 02:38 AM
Member
 
Join Date: Feb 2010
Location: South Africa
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1705
Navigtor is on a distinguished road
Re: ZJ Not starting...???

Saturday I had to sort this out, or at least get to the problem. First thing I`ve checked the power on the plug going to the pump - No power I even had the wife switch the ignition off & on... still no power, I then bridged power to the plug... and the pump works - I then check and found its not Fuel Pump relay but a other repaly activating the Fuel pump, all a sudden everything was working - then all a sudden it stopped again and no power to the pump - if I cross the relay - and it worked 100% - could it be the immobilizer?
__________________
Reply With Quote
  #19  
Old 03-16-2010, 12:53 AM
Member
 
Join Date: Feb 2010
Location: South Africa
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1705
Navigtor is on a distinguished road
Re: ZJ Not starting...???

It looks like the Shut down relay is not getting power...any ideas?
__________________
Reply With Quote
  #20  
Old 03-18-2010, 01:01 AM
Member
 
Join Date: Feb 2010
Location: South Africa
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1705
Navigtor is on a distinguished road
Re: ZJ Not starting...???

Got hold of a OBD II Diagnostic tester last night, it shows fault code:
P1389 - No ASD Relay Output Voltage at PCM

Any ideas...???
__________________
Reply With Quote
  #21  
Old 07-17-2012, 03:00 PM
CHEBcesar01's Avatar
Member
My Jeep: 1996 5.2L ZJ
 
Join Date: Jul 2012
Location: DENVER, CO
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 808
CHEBcesar01 is on a distinguished road
Re: ZJ Not starting...???

Its sounds like the problem i had with mine. Its most likely your crank sensor. check your fuel pressure before anything it should be around 44 psi i believe. I have a 96 5.2l and mine just died one day and replaced a bunch of parts and spent a lot of money and just turned out to be the crank. it runs like 80.00 at the dealer.
__________________
Reply With Quote
  #22  
Old 11-06-2012, 08:52 PM
Member
My Jeep: 1995 5.2L ZJ
 
Join Date: Nov 2012
Location: Colorado
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 737
Tuzmaster is on a distinguished road
Re: ZJ Not starting...???

The fuel pump is inside the tank i believe. You would have to drop the gas tank down to get to it. I believe at the show it costs around $800.
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
05 Limited GC 5.7 Hemi starting problem rfctexas Troubleshooting/Problems 16 10-28-2012 06:34 PM
2005 4.7L Starting Issues hamuel2003 Grand Cherokee - WK 9 03-01-2010 08:46 PM
Problem starting Jeep StoneCold Troubleshooting/Problems 15 02-23-2010 07:13 PM
Problems with 2000 4.7 v8 starting StoneCold Engine Performance/Intake/Exhaust 13 02-15-2010 11:09 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:21 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community