Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Export & Diesel Powered Jeep Models

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 01-17-2014, 07:14 PM
New Member
My Jeep: 2007 3.0L WK
 
Join Date: Jan 2014
Location: Indiana
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Badmandiesel is on a distinguished road
I have tested the glow plugs they were .8 ohms, so I think tells me they are good. Voltage to them confuses me. I see battery voltage but it did not drop after a few seconds. The check engine light has been on since I purchased the jeep, autozone said it was the maf sensor. Cleared by there code reader, key on it came right back not even stated and said maf, ok I"ll live with that. Now we are cold here 20 *f it won't start if allowed to get cold, plugged and a battery charger on it in it takes several tries. Any other ideas other than the glow control module? Right now it is stuck at my work.
__________________

__________________
Reply With Quote
  #2  
Old 02-17-2014, 06:40 AM
Frango100's Avatar
Premium Member

My Jeep: 2004 4.7L WJ
 
Join Date: Dec 2009
Location: Brazil
Posts: 4,708
Thanks: 9
Thanked 58 Times in 56 Posts
Rep Power: 525526
Frango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond reputeFrango100 has a reputation beyond repute
Re: Hard start when cold

Welcome to the garage.
Not that much experience on diesel engines, but some googling learned that a faulty MAF sensor can cause hard start problems. Since this code is there, i would start by replacing the MAF sensor first.
__________________

__________________
Frank

JEEP Grand Cherokee 4.7 Lmtd 2004
HID 8000K in low and fog / Quad Squad member
Monroe Reflex shocks / Pirelli Scorpion ATR 245/65/17 - Transgo reprogramming shiftkit.

VW Beetle 2.0 TSI 2013
My new toy
Reply With Quote
  #3  
Old 02-18-2014, 09:06 AM
paul4314's Avatar
Member
My Jeep: 2003 2.8L WJ
 
Join Date: Dec 2011
Location: staines uk
Posts: 129
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1491
paul4314 has a reputation beyond reputepaul4314 has a reputation beyond reputepaul4314 has a reputation beyond reputepaul4314 has a reputation beyond reputepaul4314 has a reputation beyond reputepaul4314 has a reputation beyond reputepaul4314 has a reputation beyond reputepaul4314 has a reputation beyond reputepaul4314 has a reputation beyond reputepaul4314 has a reputation beyond reputepaul4314 has a reputation beyond repute
Re: Hard start when cold

Quote:
Originally Posted by Badmandiesel View Post
I have tested the glow plugs they were .8 ohms, so I think tells me they are good. Voltage to them confuses me. I see battery voltage but it did not drop after a few seconds. The check engine light has been on since I purchased the jeep, autozone said it was the maf sensor. Cleared by there code reader, key on it came right back not even stated and said maf, ok I"ll live with that. Now we are cold here 20 *f it won't start if allowed to get cold, plugged and a battery charger on it in it takes several tries. Any other ideas other than the glow control module? Right now it is stuck at my work.
if this is a crd diesel engine check the injectors or leak back u need a leak back test kit for this as the injectors wear and allow to much diesel to retune to the tank and not hold fuel rail pressure
and causes hard start
this is very common a a 2.7 crd im not to sure about the 3.0 crd engine weather they suffer the same problem
with injector failure
__________________
Reply With Quote
  #4  
Old 05-04-2014, 07:46 AM
Member
My Jeep: 2008 3.0L WK
 
Join Date: Jan 2012
Location: Montreal Canada
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 953
Bora Boy is on a distinguished road
Re: Hard start when cold

Take the MAF out and get some Electrical grade or pure Alcohol (not rubbing) place it in a zip-lock bag and shake. I do this every couple of years on all my turbo cars as the MAF can get clogged with oïl blow-back. Saved my $$$$ on two cars and if it does not work it will just cost you $15.00 or so in Alcohol.
__________________
Reply With Quote
  #5  
Old 06-01-2014, 04:26 PM
Member
My Jeep: 2005 2.8L KJ
 
Join Date: May 2014
Posts: 19
Thanks: 3
Thanked 8 Times in 4 Posts
Rep Power: 331
Ranger1 has a reputation beyond reputeRanger1 has a reputation beyond reputeRanger1 has a reputation beyond reputeRanger1 has a reputation beyond reputeRanger1 has a reputation beyond reputeRanger1 has a reputation beyond reputeRanger1 has a reputation beyond reputeRanger1 has a reputation beyond reputeRanger1 has a reputation beyond repute
Re: Hard start when cold

Suggest you invest in an OBD code reader, something like one of the Innova models. Trying to troubleshoot it without a code reader is going to be time intensive and frustrating, especially in the cold when it won't start reliably.

There is more than 1 OBD code for the MAF sensor, one for open in the wiring, one for shorted wiring, and likely a couple for out of range/performance of the MAF sensor itself. Without knowing which one, it's a crap shoot to troubleshoot online.

Once you can pull all of the codes at your convenience, you can then share the exact P numbers and start from there.

Good luck.
__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
03 overland hard start Rael Troubleshooting/Problems 0 12-26-2013 02:09 PM
2014 V6 occasional hard start poorredman Trouble Shooting/Problems/Service 3 09-06-2013 12:48 PM
9 deg outside wj hard start violant00 Engine Performance/Intake/Exhaust 34 01-28-2011 12:55 AM
WJ Hard start when hot Jeep95XJ Engine Performance/Intake/Exhaust 7 08-22-2010 11:19 PM
Hard to Start '04 Grand Cherokee bbd1012 Engine Performance/Intake/Exhaust 1 07-14-2010 11:24 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community