Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Export & Diesel Powered Jeep Models

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 07-19-2013, 06:55 PM
GNHJEEP's Avatar
Member
My Jeep: 2007 3.0L WK
 
Join Date: May 2012
Location: New Zealand
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 808
GNHJEEP is on a distinguished road
I've got issues........ 07 CRD GC

So 16 months into ownership, have done 48,000kms, just about to tick over 100,000kms.
From time to time when i started up i would get a message "SERVICE PARK ASSIST SYSTEM" on the display, i then noticed it would happen while driving.
Then i noticed that the gear selector lights in the bottom of the speedo are all illuminated and it gets stuck in whatever gear you were in at the time. everytime this happens "SERVICE PARK ASSIST" comes up.
So i worked out that if i shifted the autostick a couple times it would just go back to normal, sometimes for a week, sometimes for 5 minutes.

So the latest is that when accelerating hard in any gear, usually 1st,2nd,3rd it will get near redline and just stay there, "SERVICE PARK ASSIST" comes up and you are stuck in whatever gear you were in.
Also about 800-1000rpm before redline it now "surges", almost like it has another gear, it feels like the torque converter is locking up.

the last 3 times it has done all of these things at the same time! and the battery light comes on!

Time to sell? its giving me the sh1ts!
__________________

__________________
Reply With Quote
  #2  
Old 07-22-2013, 12:57 AM
2005JGC's Avatar
Senior Member


My Jeep: 2005 4.7L WK
 
Join Date: Nov 2010
Location: Portland, OR
Posts: 2,751
Thanks: 51
Thanked 69 Times in 58 Posts
Rep Power: 1652900
2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute2005JGC has a reputation beyond repute
Re: I've got issues........ 07 CRD GC

We need codes to know for sure, but with the NAG common failures are the "shift bezel" which is the shift assembly in the vehicle. Leaks from the NAG connector causes low fluid level and causes problems, and the service park assist may be coming up due to faulty information form the shift bezel. Could also be a bad park assist sensor.
__________________
2005 Jeep Grand Cherokee - Gone but not forgotten!

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
JK Wrangler CRD :: 2013 Jeep JK CRD 2 Door frad1312 Member Garage Discussions 0 05-19-2013 09:55 PM
2014 Grand Cherokee CRD / 2014 Touareg CRD LJS8510 Diesel Powered 2012+ Export Grand Cherokee 6 04-11-2013 11:19 PM
Paint issues and windscreen issues mm1964 Export Grand Cherokee 2011+ 41 03-28-2013 09:26 PM
GC WK 3.0.CRD :: 2007 Jeep WK 3.0 CRD AÑO 2007 juruda Member Garage Discussions 0 02-02-2013 02:30 PM
Battery Issues with Aus CRD? John47 Export Grand Cherokee 2011+ 60 12-08-2012 04:03 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:44 PM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community