Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee SRT8 - WK > SRT8 General Discussion > Trouble Shooting/Problems/Service

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #13  
Old 06-09-2011, 03:20 AM
Member
My Jeep: 2007 3.0L XK
 
Join Date: May 2011
Location: Italy
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1328
filo8818 is on a distinguished road
Send a message via Skype™ to filo8818
Re: Xenon High-beam flicker issue

ok i ll....but is so strange because the relay is new and i put it yesterday...
if i activate the remote unlock light and in the morning after a night with the car in the parking i open it just one light is working and the other is totally of.
if i turn on the car ( and no the light) and i wait 15-30 second and then i switch on the light they works perfectly.
sooo strange
__________________

__________________
Reply With Quote
  #14  
Old 06-09-2011, 05:56 AM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,370
Thanks: 487
Thanked 71 Times in 68 Posts
Rep Power: 469817
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Xenon High-beam flicker issue

I had the same problem.

Cheap cheap ballast.
__________________

__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #15  
Old 06-09-2011, 06:20 AM
White WK Swagga's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: May 2009
Location: East WishAN*ggaWoods, NY
Posts: 14,384
Thanks: 8
Thanked 5 Times in 5 Posts
Rep Power: 16577
White WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond repute
Re: Xenon High-beam flicker issue

Correct me if I'm wrong

Capacitor
uses the same power lines but stored some power in it and supplies that to the load whenever it is needed.

Relay
Changes the function on the factory wiring from being the power supply wires for the load to being the wires to control the switch (relay) and the relay wires are designed to be of thick enough gage to handle the new load draw.

Therefore capacitors are not ideal nor safe for use. Relays are safer IMO and make sure you have a clean solid ground.

Now from personal experience, the flicker issue sounds like the ballast. Swap with the other side to see if the problem still exist. Also don't let this go for too long cause it damages the bulb. Always but bulbs in pairs.
__________________
The fallen......

09 WK Limited, 3.7 w/ Nav (MYGIG) W/ ipod, Single Kicker 12" CVX sub-ZX750 amp, 20" chrome SRT reps,front & reat SRT sway bars, V-LED interior & license plate, LED cargo light, Dual LED turn bulbs, painted headlight reflector covers, 5k HID lows, 3.5k/5k fogs, K&N Drop in filter, Shorty antenna, Tinted Tails & 3rd brake light, debadged.....
Reply With Quote
  #16  
Old 06-09-2011, 06:52 AM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,370
Thanks: 487
Thanked 71 Times in 68 Posts
Rep Power: 469817
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Xenon High-beam flicker issue

Yep. Bad ballast. I would get a better kit.

The ballast aren't supplying enough voltage for the bulbs. This causes flickering and the bulb not even turning on at time.

HID bulbs: low wattage, high voltage (Only on initial start up then the voltage is regulated and that's why the lights "flash" when first turned on. This is also why turning them on and off repeatedly is bad.)

The ballast generates the voltage.

And you ar right Nate.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #17  
Old 06-09-2011, 07:43 AM
Member
My Jeep: 2007 3.0L XK
 
Join Date: May 2011
Location: Italy
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1328
filo8818 is on a distinguished road
Send a message via Skype™ to filo8818
Re: Xenon High-beam flicker issue

so i have to solve it fast because i can make damage to the bulb??
so tomorrow i ll try to switch the ballast....but i guess i ll not solve nothing....
i just hope-....
__________________
Reply With Quote
  #18  
Old 06-09-2011, 07:54 AM
White WK Swagga's Avatar
Senior Member
My Jeep: 2009 3.7L WK
 
Join Date: May 2009
Location: East WishAN*ggaWoods, NY
Posts: 14,384
Thanks: 8
Thanked 5 Times in 5 Posts
Rep Power: 16577
White WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond reputeWhite WK Swagga has a reputation beyond repute
Re: Xenon High-beam flicker issue

Where are you located? I have a few old school Xentec metal ballast I'll send ya. It you can buy 35w slim ballast on eBay for under $20.
__________________
The fallen......

09 WK Limited, 3.7 w/ Nav (MYGIG) W/ ipod, Single Kicker 12" CVX sub-ZX750 amp, 20" chrome SRT reps,front & reat SRT sway bars, V-LED interior & license plate, LED cargo light, Dual LED turn bulbs, painted headlight reflector covers, 5k HID lows, 3.5k/5k fogs, K&N Drop in filter, Shorty antenna, Tinted Tails & 3rd brake light, debadged.....
Reply With Quote
  #19  
Old 06-10-2011, 10:56 AM
Member
My Jeep: 2007 3.0L XK
 
Join Date: May 2011
Location: Italy
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1328
filo8818 is on a distinguished road
Send a message via Skype™ to filo8818
Re: Xenon High-beam flicker issue

really?? for just 20 $?? i live in italy!!!! but so for u changing the ballast i ll solve the problem? thanks really sooo much
__________________
Reply With Quote
  #20  
Old 06-10-2011, 03:17 PM
lll2for3lll's Avatar
Premium Member
My Jeep: 2005 3.7L WK
 
Join Date: Dec 2010
Location: North Myrtle Beach, SC
Posts: 6,370
Thanks: 487
Thanked 71 Times in 68 Posts
Rep Power: 469817
lll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond reputelll2for3lll has a reputation beyond repute
Garage
Re: Xenon High-beam flicker issue

Quote:
Originally Posted by filo8818 View Post
really?? for just 20 $?? i live in italy!!!! but so for u changing the ballast i ll solve the problem? thanks really sooo much
You should buy a kit from Xenon Depot.
__________________
Jeep: 2005 WK | OME Lift Kit & 1.5 Rear Coil Spacers (3" of lift front & rear) | 255/75/17 BF Goodrich Mud Terrain KM1 on stock wheels (no spacers) | SCT Tuner with 93 Octane Tune | Fastman TB | K&N 77 Series | Pioneer 7" Double Din | Pioneer D-Series 6 Speaker Upgrade | Custom Rear Peek-A-Boo Camera | 5K TRS XB35 HID Bulbs & Mini Morimoto Retrofitted Projectors | Parking Lights Deleted | PIAA 510 in OEM foglight location modded for OEM foglight harness | 6K V-LEDS Reverse | 5K V-LEDS License Plate | 6K V-LEDS Interior | Custom Overhead Console Blue Ambient Light | LXHarness Complete Blue Interior Upgrade | 5% on top of 20% Tint & 50% on the whole windshield | Debadged
Bike: 2009 Yamaha Raven R1 | CrossPlane | Far from stock | Quicker/Faster than your SRT
Reply With Quote
  #21  
Old 06-10-2011, 03:40 PM
Member
My Jeep: 2007 3.0L XK
 
Join Date: May 2011
Location: Italy
Posts: 79
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 1328
filo8818 is on a distinguished road
Send a message via Skype™ to filo8818
Re: Xenon High-beam flicker issue

Quote:
Originally Posted by lll2for3lll View Post
You should buy a kit from Xenon Depot.
is a seller on ebay? my kit is really low quality...but he sand me 4 ballast and i pay for 2...he make a mistake....so i can try to change the one that sometime is now working with onother one and test if the problem is still there...in that case will be the realy...
is soo complicated..im more than 2 month that im trying to have my xenon light and all time i found some problem...
btw thanks a lot for the support...
__________________

__________________
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
GEN 3 ebay questions high beam RYANSWJ Visual Modifications 4 03-03-2010 10:45 PM
wj HID low beam kit Motteler621 Interior/Exterior/Visual 21 02-09-2010 07:50 PM
Xenon lights... chicago_jeepster_ Visual Modifications 27 01-24-2010 04:59 PM
What plug and play hi beam bulbs should I get for my 08? suzieque Visual Modifications 26 10-17-2009 08:11 PM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:08 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community