Go Back   Jeep Garage - Jeep Forum > Jeep Platform Discussion > Grand Cherokee SRT - WK2

Join Jeep Garage Today
Reply
 
Thread Tools Display Modes
 
  #1  
Old 11-20-2013, 08:39 PM
14srt's Avatar
Member
My Jeep: 2014 6.4L WK2
 
Join Date: Jan 2013
Location: Chicago, IL
Posts: 96
Thanks: 7
Thanked 5 Times in 5 Posts
Rep Power: 813
14srt is on a distinguished road
Missing 2nd and 3rd gear when cold, major shift lag when fully warm

First off, I feel bad that it seems anytime I post on here it is regarding a issue I am having and not contributing to threads/discussion. I have had a pretty extensive list of issues with my 14 since new but this is an all time bad.

It started with the dreaded oil leak. Pools of oil on the garage floor every morning and the smell of burnt oil during my drive home from work. The dealer blamed a bad filter and did a shoddy job of cleaning up the oil and it still smelled when driven hard for about 2 months. Then I brought it in for the new rear shaft due to the deceleration whistle. While the whistle went away I now get a loud "supercharger whine" when the car is driven harder then 3/4 throttle. Many occupants have asked if the beast is supercharged due to how loud the whine is. Well, it's definitely not! Additionally, since the car was new it has had a very detectable vibration between 2200-3100 rpm. No matter how much gas I give it or what gear I'm in.

In the past few weeks I started to notice a lag between shifts when the car was in D. I assumed I was just used to keeping it in S and left it alone. Then, about 2 weeks ago I was showing off for a coworker and did a launch while entering an on ramp. The car whined it's way to 2nd where it did not shift, killed all of the power and forced me to pull over and idle to a stop. I took back off at a normal pace and everything seemed fine. Now this week, when I first start the car i can not even give it half throttle without the car refusing to shift from 1-2 or 2-3. When it does shift it is with a thud and a looong lag It's scary, embarrassing, and probably getting to the point of unsafe. I have a dealer appointment on Monday which was the soonest they could get me in with a loner. (which I practically begged the srt hotline for).

Does alone else have these transmission issues?! I have herd of some 3.6 drivers having issues but the srt forums have been quiet.

Thanks everyone!

My issues:
Horrible shifts
Whine sounds when accelerating
Rancid smelling HVAC
Oil leaking
Drivetrain whistle (fixed)
__________________

__________________
2014 Bright White SRT
Reply With Quote
  #2  
Old 11-20-2013, 11:14 PM
phillysrt's Avatar
Premium Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: Jul 2012
Location: Philadelpha, PA
Posts: 918
Thanks: 217
Thanked 71 Times in 64 Posts
Rep Power: 1890
phillysrt has a reputation beyond reputephillysrt has a reputation beyond reputephillysrt has a reputation beyond reputephillysrt has a reputation beyond reputephillysrt has a reputation beyond repute
Garage
Man that's tough. I have not experiences anything like that at all. I had alittle bit of a hard time with mine when I first got it but it was little odds and ends. Keep us posted as to what happened. Maybe try to get a video??? Goodluck and keep us posted
__________________

__________________

Dominic From Philly
2014 SRT DEEP CHERRY RED
2010 GC SRT8 (Retired But Not Forgotten)
Reply With Quote
  #3  
Old 11-20-2013, 11:30 PM
14srt's Avatar
Member
My Jeep: 2014 6.4L WK2
 
Join Date: Jan 2013
Location: Chicago, IL
Posts: 96
Thanks: 7
Thanked 5 Times in 5 Posts
Rep Power: 813
14srt is on a distinguished road
I actually did get a video this morning. I will try another tomorrow and post the link here in the afternoon.
__________________
2014 Bright White SRT
Reply With Quote
  #4  
Old 11-21-2013, 07:16 AM
mrmaker's Avatar
Premium Member
 
Join Date: Feb 2013
Location: The Hills, Sydney
Posts: 356
Thanks: 37
Thanked 28 Times in 22 Posts
Rep Power: 1395
mrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond repute
Re: Missing 2nd and 3rd gear when cold, major shift lag when fully warm

I feel for you buddy, i hope your troubles end soon. I like Philly have had minor issues not worth a mention in comparison to yours, let us all know how it pans out for you.
__________________
Reply With Quote
  #5  
Old 11-23-2013, 01:37 PM
lillyjas's Avatar
Premium Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: Apr 2013
Location: Lansing, MI
Posts: 220
Thanks: 0
Thanked 25 Times in 20 Posts
Rep Power: 896
lillyjas has a reputation beyond reputelillyjas has a reputation beyond reputelillyjas has a reputation beyond repute
Garage
I have had the oil leak issue, had an evap sensor go out, but otherwise pretty good... I still hear a little exhaust rattle when going through a drive thru... But they said was normal. Did have to replace plastic piece on dash as it was warped...

Got mine 4-30-13 and was on the lot for 12 days so must have been an early build, but appears I am lucky thus far
__________________
"Dark Shadow"- 2014 Jeep GC SRT

BT Catch Can, InJen CAI, Tint all around, debadged, Tinted tail lights, Vinyl Wrapped Window Trim, Eibach ProKit, Black Powdercoated Borla ATAK, 87mm TB, CFR front splitter, Cross Drilled Brembo Sport Brakes w/Hawk Pads

Pure Michigan
Reply With Quote
  #6  
Old 11-23-2013, 01:45 PM
Scottina06's Avatar
JeepGarage Founder
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: May 2009
Location: Berea, Kentucky
Posts: 49,657
Thanks: 896
Thanked 1,131 Times in 776 Posts
Rep Power: 7718657
Scottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond reputeScottina06 has a reputation beyond repute
Garage
Re: Missing 2nd and 3rd gear when cold, major shift lag when fully warm

any repairs done? sounds like a bad tcm
__________________
SCOTT
The HARDER you work...the LUCKIER you are!
2014 REDLINE red Jeep SRT "BLOODIED\BlackOps CFR Edition" 1 of 1
2013 JKU Wrangler 10A-stormtrooper'ed, JW Speaker and more!
Previous JEEP rides-
2013 Jeep Grand Cherokee SRT-deep cherry
2006 Jeep Grand Cherokee Laredo-inferno red



Twitter-The_Jeep_Guy
Instagram-thejeep_guy

Reply With Quote
  #7  
Old 11-25-2013, 02:33 PM
14srt's Avatar
Member
My Jeep: 2014 6.4L WK2
 
Join Date: Jan 2013
Location: Chicago, IL
Posts: 96
Thanks: 7
Thanked 5 Times in 5 Posts
Rep Power: 813
14srt is on a distinguished road
Re: Missing 2nd and 3rd gear when cold, major shift lag when fully warm

I finally got it into the dealership today. I was under the car on Saturday and noticed a lot of oil/fluid around the transmission. I think i have a considerable leak in there. It shifted like crap all weekend and had some unbelievably hard downshifts on my way to the dealer today. Lets hope they just swap that puppy out for a new tranny!!!

I posted a video here:

Don't mind the pissed off tone in my voice... haha!
__________________
2014 Bright White SRT
Reply With Quote
  #8  
Old 11-25-2013, 06:09 PM
mrmaker's Avatar
Premium Member
 
Join Date: Feb 2013
Location: The Hills, Sydney
Posts: 356
Thanks: 37
Thanked 28 Times in 22 Posts
Rep Power: 1395
mrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond repute
Re: Missing 2nd and 3rd gear when cold, major shift lag when fully warm

Quote:
Originally Posted by 14srt View Post
I finally got it into the dealership today. I was under the car on Saturday and noticed a lot of oil/fluid around the transmission. I think i have a considerable leak in there. It shifted like crap all weekend and had some unbelievably hard downshifts on my way to the dealer today. Lets hope they just swap that puppy out for a new tranny!!!

I posted a video here:

Don't mind the pissed off tone in my voice... haha!
I would be pretty pissed off if my SRT was doing the same, if it is tranny, which it sounds as though it is given all the oil underneath, i would push for a new replacement. Hopefully the dealer does the right thing by you.
__________________
Reply With Quote
  #9  
Old 11-26-2013, 01:44 PM
Member
My Jeep: 2014 6.4L SRT8 WK2
 
Join Date: Nov 2012
Location: United Arab Emirates
Posts: 129
Thanks: 0
Thanked 7 Times in 7 Posts
Rep Power: 902
K_SRT8 is on a distinguished road
Re: Missing 2nd and 3rd gear when cold, major shift lag when fully warm

Maybe you have a defected car, they should replace the car with new one if it is like that from the day you bought it.
__________________
Reply With Quote
  #10  
Old 12-05-2013, 05:18 PM
14srt's Avatar
Member
My Jeep: 2014 6.4L WK2
 
Join Date: Jan 2013
Location: Chicago, IL
Posts: 96
Thanks: 7
Thanked 5 Times in 5 Posts
Rep Power: 813
14srt is on a distinguished road
Re: Missing 2nd and 3rd gear when cold, major shift lag when fully warm

Well.... after 11 days in service they called and said the vehicle was ready fow pickup! I was told that the two issues addressed were a TCM reflash and a new transfer case seal as it was leaking fluid. I was honestly very surprised that it was only a software issue considering it felt very mechanical to me.

So.... i drove off the lot after waiting for the engine to heat up a bit and gave it about 75% throttle on the freeway on ramp about a mile away. 1-2 shift successful!!! 2-3... no shift then hit rev limiter, killed power and then griped onto 4th and away I went. I got off at the next exit and tried a full throttle re-merge. Car had no idea what to do at redline, abruptly shifted into i believe 2nd for a moment, then 3rd, then back to 2nd, all while not making any forward movement after its first attempt. Needless to say I was back in the service drive minutes later. They are at a loss and will prob have the car for another long chunk of time. A week more and I might be the first 2014 SRT owner on the forum to lemon law this POS. I would not ask for a refund, I truly like the car (when its running well) and just want an exact replacement if it cant be fixed this time.

Anyways, thanks for letting me rant! Im getting quite comfortable in my 170HP GMC terrain....
__________________
2014 Bright White SRT
Reply With Quote
  #11  
Old 12-06-2013, 06:48 AM
mrmaker's Avatar
Premium Member
 
Join Date: Feb 2013
Location: The Hills, Sydney
Posts: 356
Thanks: 37
Thanked 28 Times in 22 Posts
Rep Power: 1395
mrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond reputemrmaker has a reputation beyond repute
Re: Missing 2nd and 3rd gear when cold, major shift lag when fully warm

I feel for you man, your situation is not good. It is obvious that they don't know what the problem is, hence have no way of fixing. The way you describe the cars reaction sounds dangerous to you and those around you. I would be pushing hard and not be accepting anything other than a replacement.

Wish you all the best.
__________________
Reply With Quote
  #12  
Old 12-06-2013, 12:49 PM
Chunderboy's Avatar
Senior Member
 
Join Date: Apr 2013
Posts: 1,235
Thanks: 5
Thanked 43 Times in 30 Posts
Rep Power: 92994
Chunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond reputeChunderboy has a reputation beyond repute
Re: Missing 2nd and 3rd gear when cold, major shift lag when fully warm

That has got to be a terrible feeling. Good luck with the outcome and hope you can get into a new one (minus the problems).
__________________

__________________
2013 E-Group 4x4 in True Blue
Front and rear Blackhorse bumper guards
2013 Sahara Unlimited Anniversary wheels wrapped in 255/70R18 Bridgestone Dueler
Updated to 430N RHB Radio w/NAV
Crazy with the Plasti-dip
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are Off
Pingbacks are Off
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
CRD MY2014 Engine Noisy When Cold - & Auto Gear Shift Jerky Jjhohan Export Grand Cherokee 2011+ 37 06-01-2014 06:26 PM
Question about 2nd and 3rd gears HemiDawg Grand Cherokee - WK 5 03-29-2011 08:47 AM
hard, rough downshifts to 2nd, 1st gear ??? CLowe40 Trouble Shooting/Problems/Service 21 02-03-2011 11:57 PM
Grinding/Vibration from 2nd to 3rd Gear dowdy85 Trouble Shooting/Problems/Service 3 10-31-2010 11:06 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:16 AM.


Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community

JeepGarage.org is in no way associated with or endorsed by Chrysler Group LLC.