Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Electrical problems (video) (http://www.jeepgarage.org/f77/electrical-problems-video-10454.html)

DezeWJeep 06-19-2010 10:21 PM

Electrical problems (video)
 
Hello, I am new to this forum, I just recently purchased a 99 GC Laredo v8 about 2 weeks ago. Everything was going great until 3 days ago. I started having issues with the windows not working, and the gauges clicking sometimes, then yesterday, everything electrical started going haywire. It still starts and drives, but the following do not work: windows, sunroof, heat/ac, turn signals, headlight. The hazards stay on all the time, and the door locks work occasionally. The gauges however are VERY erratic. All of the lights flicker on and off, and the needles sweep side to side (shown in video). Also, when I switch the headlights on, it makes a fast clicking sound. I checked all fuses, relays, and tried replacing the hazard/turn signal switch.

I had a leak under the dashboard, which I think I fixed, and water was dripping down by the fuse box. I am wondering if maybe the water fried the BCM?

Any input would be greatly appreciated.

Here is the address to the video
http://www.youtube.com/watch?v=RDWvdIjvRO0

Thank you

Scottina06 06-19-2010 10:37 PM

Re: Electrical problems (video)
 
HOLY SMOKES! That baby has a poltergeist! J/K! Thats gonna be hard to diagnose on the internet...but maybe one of the WJ guys has seen this before???? Very odd

StoneCold 06-20-2010 07:08 AM

Re: Electrical problems (video)
 
Dude, you need a Priest and some holy water!!

Seriously though, I've never seen anything like that before:eek:. The weird thing is, the gauges seem to move almost in sync. I would have thought that if the electrics were fried, they'd either not work at all, or be a bit more sporadic.

DezeWJeep 06-20-2010 10:46 AM

Re: Electrical problems (video)
 
Yea, I've never seen anything like it either. Hopefully someone can point me in the right direction. I'm sure the stealership would charge me alot to diagnose it. I'm going to try and locate a used BCM, and see if that helps. If anyone else has some ideas, lmk? thanks again

Scottina06 06-20-2010 12:39 PM

Re: Electrical problems (video)
 
could the gauge cluster have gotten some water in it?

SvenskaJeepGuy 06-20-2010 01:31 PM

Re: Electrical problems (video)
 
mine did that in my WJ after a big rainstorm once and then it stopped a few days later

DezeWJeep 06-20-2010 04:14 PM

Re: Electrical problems (video)
 
Quote:

Originally Posted by Scottina06 (Post 224461)
could the gauge cluster have gotten some water in it?

I don't think so, the water was coming down the side of the dash, by the kick panel/fuse box. I removed the cluster, and showed no signs of water damage. Im at a loss here. I might have to try the dealer :gasp!!: I've checked everything I could think of. Took out all the fuses/relays, and checked for corrosion. Made sure all of the wires were dry etc. and nothing.

SvenskaJeepGuy 06-20-2010 04:35 PM

Re: Electrical problems (video)
 
water got in the fuse box

Scottina06 06-20-2010 05:30 PM

Re: Electrical problems (video)
 
I would pull the fuses one by one and clean any corrosion off with alcohol swabs. You can also try to clean the holes they fit into with something. Not sure how much of a problem it would be to replace all the fuses and the fuse box itself????


All times are GMT -5. The time now is 06:00 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community