Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f181/)
-   -   Transmission Over Temp (http://www.jeepgarage.org/f181/transmission-over-temp-10665.html)

bullet700 06-28-2010 07:52 PM

Transmission Over Temp
 
Dats the message i get on the dashboard of my '05 WK: TRANSMISSION OVER TEMP, with a check engine light on. it happened this morning. then i turn the car off, and turn it on again the message was gone and the check engine light was gone as well. has anybody experienced this before? wat seems to be the issue here? i noticed that the car has been acting weird too. at red light, when the folks in front of me start moving. i hit the gas, the car starts moving but very slowly, so slow the people in front of me would be far in front and the people behind start honking pro'bly saying "ARE U GONNA START F****** MOVING OR WAT?"

robpp 06-28-2010 08:06 PM

Re: Transmission Over Temp
 
it needs trans fluid.

let me guess, you have no dipstick and no one has ever checked it?????

DJ BoNiOmArIo 06-28-2010 10:00 PM

Re: Transmission Over Temp
 
does it shift gears or stuck in one gear?

this thread might help

http://jeepgarage.org/showthread.php...ght=prnd+bezel

or another thing is the starter ... yes sounds weird but the starter does trigger that code

bullet700 06-29-2010 09:57 AM

Re: Transmission Over Temp
 
it has a deep stick. and i get the tranny fluid check when they do the engine oil change. but yeah, after some google search i found out this is a pretty common problem with the TRANSMISSION OVER TEMP message. it's a sign that you soon need to change your starter. weird, i know.
well thank you guys!

wuwersaukas 04-11-2012 01:29 PM

Re: Transmission Over Temp
 
I am currently getting the Transmission Over Temp message but I just had a trans service done and I replaced the starter last year (for the 3rd time). The trans levels are find. Does anyone have any suggestions on what else to check?

Bikemobile 04-11-2012 07:13 PM

Re: Transmission Over Temp
 
Quote:

Originally Posted by bullet700 (Post 228123)
it has a deep stick. and i get the tranny fluid check when they do the engine oil change. but yeah, after some google search i found out this is a pretty common problem with the TRANSMISSION OVER TEMP message. it's a sign that you soon need to change your starter. weird, i know.
well thank you guys!

Wut

jtgross30 05-08-2013 03:37 PM

Re: Transmission Over Temp
 
Quote:

Originally Posted by wuwersaukas (Post 611208)
I am currently getting the Transmission Over Temp message but I just had a trans service done and I replaced the starter last year (for the 3rd time). The trans levels are find. Does anyone have any suggestions on what else to check?

did you ever find a solution to this problem. i have same issue on my 2006 hemi JGC.

jtgross30 05-08-2013 03:39 PM

Re: Transmission Over Temp
 
had car fluids changes and same thign trans over temp warning and fan turning on. any ideas

Combat 05-08-2013 05:34 PM

Re: Transmission Over Temp
 
I had the same issue with the trans over temp and fan coming on, had a transmission shop check the temperature and it was spiking up and down all over the place; however, when they checked the trans dip stick it was ice cold. They told me it was possibly a faulty sensor within a solenoid pack inside the trans.

Nonetheless, I didn't end up getting it fixed and eventually it ended up evolving into incorrect gear ratio codes and was told I needed a new transmission due to the fact my jeep would push into second gear. But thats just my jeep, who know yours might be a different situation.

Maybe you just have a faulty sensor, or something much worse? I would get it checked out immediately, could save you some money in the end.

Stage 3 trans on the way!!!! Ill keep you guys updated, this new trans should fix the issue. If not, then theres a bigger problem.

fcdd25 05-15-2013 01:33 PM

Re: Transmission Over Temp
 
I've been having the same problem since June 2010 on my '06 GC 4.7L. Trans always shifts fine when TOT is not on. Couldn't find answers by asking dealers or local shops or surfing web.

Bought an infrared thermometer and for awhile when light came on I pulled over and shot the ray at tranny pan. Temp was always at 180 degrees (give or take a few) which is spec. Had fluid/filters replaced at dealer in January and it still comes on at times. It seems to go in streaks: nothing for a few weeks and then on/off for a few weeks. No pattern.

Realized this is probably just another of the many electrical glitches our Jeeps have and decided not to worry about it any more. Have driven about 45-50000 miles since first incident and tranny seems fine so far. If I ever find an answer I will post it. In the meantime make sure your fluid is always full and only use ATF+4 and don't lose sleep over it.

huskyenergy91 05-28-2013 09:15 AM

Re: Transmission Over Temp
 
Bump....any new info on this?

Laredo2006 06-19-2014 10:12 PM

Re: Transmission Over Temp
 
anything new ?

getting the same message, started getting it a day after I gave a long boost to a friend's car, had negative side wire connected to his battery instead of metal surface, not sure if any of this played a role....

I also had a water pump installed 1 month prior, bought a Cardone water pump fro rockauto and brought it to some bozo mechanic shop, I wonder if things went wrong there.

I'm going to the dealer tomorrow morning, if anyone has any more clues as to what it could be...I got the 2nd message today, got the first 2-3 days ago. Transmission Over Temp. Jeep is running ok, but I may be noticing a slight louder than usual fan noise...I could be wrong there though, it could be me wanting to hear the problem... I hope it's electrical.


All times are GMT -5. The time now is 12:32 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community