Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Transmission Downshifting at Cruise Speed (http://www.jeepgarage.org/f77/transmission-downshifting-at-cruise-speed-11010.html)

Eaglelope 07-12-2010 07:58 AM

Transmission Downshifting at Cruise Speed
 
I have a 2005 WK Grand Cherokee, 4.7L

The tranny is doing an odd thing fairly regularly. I'll be driving along at 60mph or so and it will shift out of overdrive. Sometimes it feels like it's kicking down into 3rd. Then just as suddenly, it'll go back to normal.

I've replaced the TPS and both input/output speed sensors on the transmission. The only DTC being thrown showed the right rear wheel speed sensors was indicating "implausible distance" so that's been replaced too.

I replaced the TPS and the I/O sensors myself but I saw a note in the service manual that indicates an ETC Relearn is needed after TPS replacement which sounds like a trip to the dealer.

Just to add to the fun, I've recently gotten two intermittent "SERVICE ELEC BRAKE SYSTEM" messages. Not sure if this is related or not.

Thoughts or suggestions?

maxst2 07-16-2010 11:01 PM

Re: Transmission Downshifting at Cruise Speed
 
Are you in cruise control when this happens?

Mine will do that if im going down a hill and it'll speed up so cruise will kick it down and basically engine brake it.

SvenskaJeepGuy 07-16-2010 11:22 PM

Re: Transmission Downshifting at Cruise Speed
 
mine does the same thing maxst2 described

PinkJeepGirl 07-16-2010 11:30 PM

Re: Transmission Downshifting at Cruise Speed
 
might try toque converter..mine Cherokee was doing something similar when mine was going bad

Escape 07-17-2010 12:05 AM

Re: Transmission Downshifting at Cruise Speed
 
Get the relearn done and check your speed sensors on each wheel.

Eaglelope 07-20-2010 03:25 PM

Re: Transmission Downshifting at Cruise Speed
 
No, this is happening without using cruise control. Just driving on a flat road with my foot on the gas at steady speed.
Just updated my post in the WK forum but the dealer was finally able to replicate and they think it's the PCM. Should know in a few days when the new one comes in.

Thanks for the ideas. I'll let you know what happens.

Eaglelope 07-25-2010 09:44 AM

Re: Transmission Downshifting at Cruise Speed
 
Well it's fixed I think. :) The PCM swap didn't solve the problem. The dealer ended up changing the TPS and that appears to have taken care of it. That's a bit weird since I had already replaced the TPS but I suppose it could have developed an issue.
Either way, things have been running much better for the last few days.

I replaced the rear wheel speed sensors and the brake system messages stopped. I planned to do the fronts but couldn't get the front rotors off (yes, I removed the O-ring and used a big hammer :) )

Scottina06 07-25-2010 03:23 PM

Re: Transmission Downshifting at Cruise Speed
 
you couldnt get the sensor off without removing the rotor? It takes a little contortion...but I heard it can be done. Its just held on the hub with one small screw

Eaglelope 07-25-2010 03:47 PM

Re: Transmission Downshifting at Cruise Speed
 
I'll take another look. It was hitting 104 when I was working on it so my patience was a bit thin. The rear sensors were fairly simple with asingle bolt. Just took a little elbow grease to get them to slide out.


All times are GMT -5. The time now is 09:59 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community