Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   AC not working on passenger side? (http://www.jeepgarage.org/f5/ac-not-working-on-passenger-side-11094.html)

hobbes630 07-15-2010 01:22 PM

AC not working on passenger side?
 
hey guys....its starting to get pretty hot in Chicago 95+ and my ac seems to only be working half of the time. It blows pretty cold air on the drivers side only....the air blowing out of the passenger side seems to be the same temp as the air inside the car. I've tried all the different temp settings and what not....it still does it regardless....I thought I might be low on refrigerant so I bought some and toped it off so I know the system is full. It really wasn't low to begin with so I don't think that was the problem anyways.

Also I feel like sometimes it blows ice cold air in the drivers side and sometimes it blows only mildly cold air. Any ideas of what could be up? Is the compressor going bad or is there just some valve thats not letting cold air in the passenger side?

Any ideas would be appreciated...I'm moving to FL in a few weeks and its defiantly hotter there than in Chicago so if the AC can't keep up with the heat here then I'm gona really feel it there.

Scottina06 07-15-2010 02:43 PM

Re: AC not working on passenger side?
 
thats odd that it blows cold on the drivers side and is warm on the passenger side. Do you have the dual zone HVAC?

howiedodat 07-15-2010 04:35 PM

Re: AC not working on passenger side?
 
My 2005 Limited has the dual zone AC. The other day it did just what yours did , cold only on the drivers side. Mine "fixed" its self. Its ok now. Hope you find what it is so I can start saving for the repairs.

hobbes630 07-16-2010 01:18 PM

Re: AC not working on passenger side?
 
Yep its got the dual zone hvac ...heat works fine just noticed the ac was doing it when it started getting really hot out.

jeepcolorado 07-17-2010 02:42 PM

Re: AC not working on passenger side?
 
Had the same problem with my 2005 Limited 5.7L WK with 113,000 for several months, but never took it in as I thought it was some kind of serious problem with the duel zone hvac and the driver's side was cold enough.

Finally had a chance to have someone look at it in the shop and adding refrigerant fixed it good as new.

mjl2610 07-17-2010 06:32 PM

Re: AC not working on passenger side?
 
It could be something funky with the blend door not functioning at 100%. A bad actuator getting stuck maybe giving a intermittent operation perhaps? Might be worth looking there as well. Nice to see another Chicago area member on the forum. I'm from Glen Ellyn.

Jeep Trick 07-17-2010 08:48 PM

Re: AC not working on passenger side?
 
I have exactly the same problem but have yet to address it

Keep us posted, I am hoping to get it to a dealer and have it done under warranty

Any change it is a sensor????

mjl2610 07-24-2010 03:00 PM

Re: AC not working on passenger side?
 
Probably not a sensor. However, has anyone gotten this issue resolved? It would be a nice thread to have a solution to as others may have this problem in the future. Keep the forum posted.

konarider94 07-25-2010 09:49 PM

Re: AC not working on passenger side?
 
ive read about this problem on a different forum before. As strange as it sounds it usually is a low refrigerant problem. It doesnt seem like you would get cold air from either side with low freon but for whatever reason you lose cold on the passenger side first.

edit: i should add that ive seen this problem in multiple posts. this means you have a slow leak, with enough time your a/c will stop working all together.

05quadratrac 07-27-2010 04:44 PM

Re: AC not working on passenger side?
 
I know the WJ's had a blend door issue, my parents has it. The passanger side will sometimes get no air, sometimes cold air when the heat is on and sometimes hot air when the a/c is on. Luckly I have not had this issue with my WK.

howiedodat 08-03-2010 06:29 PM

Re: AC not working on passenger side?
 
Well, mine went from not working on the passengersid to not working at all Sunday afternoon while sitting in traffic. Worked better once we were moving. Just put in a 14 oz can of refrigerant in the Jeep. It took the whole can and the pressue was in the red until the can was in the system, now its in the green ( my gauge on my charging tool) and the compressor is not cycling as fast. I will let you know how it holds up. Seems it is as some folks reported, just need a refill. Does anyone know how much refrigerant the system holds ? Should I try to put in more ? Thanks !!

JGC06KSA 08-21-2010 07:10 AM

Re: AC not working on passenger side?
 
I had the sam problem. Re-charged the freon and it is chilling cold when outside 45 degree Celcius.


All times are GMT -5. The time now is 03:59 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community