Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   HID problem in 05 wk (http://www.jeepgarage.org/f5/hid-problem-in-05-wk-11164.html)

BillaWha? 07-18-2010 04:52 PM

HID problem in 05 wk
 
my buddy installed hids in my wk and they work but when u turn the lights off they trip out and then when u turn them back on the they wont work.

but if u un plug them and plug them back in they do the small thing. its hard to explain but if some one could help me out id appreciate it.
and anyone else have this problem?

robpp 07-18-2010 05:03 PM

Re: HID problem in 05 wk
 
there are prolly 20 or more hid problem threads.

about half are becuase a relay harness was not used. some places you have to ask for it. of the other half, about half of them is due to a faulty or bad ground. the rest is the hardware. bulb or ballast.

so if its happening to all. the lights lets go to step one:

1. did you use a relay harness? and either way, if you want help, please either post a pic or a drawing of exactly how you wired these lights. as i said, half of all problems are sloveld here

White Chocolate 07-18-2010 07:59 PM

Re: HID problem in 05 wk
 
Quote:

Originally Posted by BillaWha? (Post 237330)
my buddy installed hids in my wk and they work but when u turn the lights off they trip out and then when u turn them back on the they wont work.

but if u un plug them and plug them back in they do the small thing. its hard to explain but if some one could help me out id appreciate it.
and anyone else have this problem?

Yes man, we need more info

B.P.O.D 07-19-2010 10:06 AM

Re: HID problem in 05 wk
 
relay or ground 99% of problems on hid kits when installed

White Chocolate 07-19-2010 11:40 AM

Re: HID problem in 05 wk
 
I wish people would search...LOL :)

sweetjeep99 07-19-2010 12:27 PM

Re: HID problem in 05 wk
 
had the same problem. get the relay harness. my lights were strobing , could'nt get it to stop for nothing. all my jeepgarage buddies told me to get that relay harness, so i did, problem solved. thanks guys

sweetjeep99 07-19-2010 12:36 PM

Re: HID problem in 05 wk
 
Talk to Steve from XenonDepot. he will hook you up with what you need. he's a really good guy to work with. he's been a BIG help to me.

SvenskaJeepGuy 07-19-2010 12:52 PM

Re: HID problem in 05 wk
 
Quote:

Originally Posted by KlutcH (Post 237756)
I wish people would search...LOL :)

someone needs to post that search gif again lol or make the HID problem a sticky in problems thread

felixchaz10 10-23-2010 11:00 PM

Re: HID problem in 05 wk
 
got a simuler problem wen i mes wit mi kit on en off the pasenger headlight turns of??

is that because i need the harnest???

Scottina06 10-23-2010 11:06 PM

Re: HID problem in 05 wk
 
yes...and proper grounds

TheAngryMinnow 10-24-2010 12:51 AM

Re: HID problem in 05 wk
 
Quote:

Originally Posted by KlutcH (Post 237756)
I wish people would search...LOL :)

you spend more time suggesting that than helping. this is a discussion forum, get used to it.

and it sounds like a relay problem if theyre flickering wildly. can you upload a video>?

GR33N D3M0N 10-24-2010 11:40 AM

Re: HID problem in 05 wk
 
Quote:

Originally Posted by TheAngryMinnow (Post 289717)
you spend more time suggesting that than helping. this is a discussion forum, get used to it.

and it sounds like a relay problem if theyre flickering wildly. can you upload a video>?

look at the date, i dont think hes gonna be posting a vid, and the reason why we suggest people searching is so it doesnt clutter up the servers, and the site goes down, there is absolutely no point in making a thread, when there is another thread just like it, and all you have to do is search...

EDIT: +rep for felixchaz10 for using the search :D


All times are GMT -5. The time now is 02:23 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community