Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Missing Relays? (http://www.jeepgarage.org/f203/missing-relays-11249.html)

heehawbus 07-21-2010 04:28 AM

Missing Relays?
 
So i took a little peak in my relay box tonight (a/c isnt working, hoped it was the relay, not so much :( ) and while i was in there i noticed i had TWO missing relays.. both of them are for the "front and rear O2 sensors".. I have no codes, truck runs normal for the most part, bad milage (13.5 avg, but sorta normal) but i cant imagine that they arnt supposed to be there..

ive had some exhaust work done (flowmaster and bigger pipes in 2006 and magnaflow hi-flow this year) but wouldnt think that the shops would have taken the relays out.. are they even supposed to be there? ive always passed smog and have no OBD codes..

Some one with a 4.7L WJ wanna check their relay box under the hood and lemme know what they find? ;)

CherokeeOnToyos 07-21-2010 05:55 AM

Re: Missing Relays?
 
I'll do it...but i dont have a camera, wanna upload a pic of yours and i'll tell you whats different/missing :thumbsup:

Frango100 07-21-2010 05:19 PM

Re: Missing Relays?
 
According the jeep service manual the 2 relays you are talking about are the oxygen sensor heating relays. There are 2 layouts for this heating system; one is using these 2 relays and the other is using the ASD relay for the same function. So it appears that you have the second layout.

heehawbus 07-21-2010 06:13 PM

Re: Missing Relays?
 
this isnt mine but its close.. on mine number 34 and 35 are both missing.
for some reason tho this picture calls them the o2 sensor and backup lamp.. but ya my chart calls them rear o2 sensor and front o2 sensor.. http://www.wjjeeps.com/misc/power_dist_ctr_02.jpg

CherokeeOnToyos 07-21-2010 06:22 PM

Re: Missing Relays?
 
yea thats what mine looks like, 2002 4.7L V8 HO...This is what mine looks like

http://i341.photobucket.com/albums/o...3/DSCF5604.jpg

heehawbus 07-21-2010 06:29 PM

Re: Missing Relays?
 
hmm.. looks like you have one of the ones im missing.. weird

CherokeeOnToyos 07-21-2010 06:32 PM

Re: Missing Relays?
 
yea, mine looks like the pic on WJJeeps.com, maybe its like Frank said



Quote:

Originally Posted by Frango100 (Post 239423)
According the jeep service manual the 2 relays you are talking about are the oxygen sensor heating relays. There are 2 layouts for this heating system; one is using these 2 relays and the other is using the ASD relay for the same function. So it appears that you have the second layout.


heehawbus 07-21-2010 07:13 PM

Re: Missing Relays?
 
ya must be.. anyone else have a different setup in their wj?


All times are GMT -5. The time now is 02:17 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community