Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   3.7L GC - Limp Mode P0762 P0763 NEED HELP !!! (http://www.jeepgarage.org/f77/3-7l-gc-limp-mode-p0762-p0763-need-help-11408.html)

DJ BoNiOmArIo 07-27-2010 08:29 AM

3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
Some of you may know what the current problem is, so I'll try to make this brief as possible

Vehicle - 2006 GC V6 3.7L NAG 1 (W5A580) Transmission 4x4 w/ 80K miles

Symptoms

LIMP MODE, only happens when I turn off the car and turn it back on after a couple of minutes.

If I keep the hood open then it does not happen.

Last night I turned off the car left the hood closed and started it after 20 minutes of being shut it went into limp mode.

A couple of hours later tried it with the hood open and started right back up with no problems, so now everywhere I go I have to keep the hood open if I'm going to be a couple of minutes :lol:

The codes that I still get are:

P0762 "Shift Solenoid C Stuck On"
P0763 "Shift Solenoid C Electrical" and once a while I get ...
P0710 "Trans fluid temp sensor circuit malfunction"

I have changed the following parts so far ...

Part # 52108308AB - 13 pin connector that is on top of the valve body that contains the circuitry for the temp sensor, speed sensor and all the solenoids $250

Solenoids - Changed out all 3 shift solenoids $160

Starter $100

Battery $150

PCM (TCM is a part of it) $200

Shifter Bezel and whole entire shifter assembly $300

Flashed everything at the dealer ... $95

Almost $1250 just in parts !!!!

So I'm stuck, I don't know what to look for anymore, it is seriously retarded how it only happens when the hood is kept shut and clearly temp related to something that throws the whole phucking car into limp mode !!!

I don't know what to do except the last thing that comes to mind is the wiring harness or the connectors but which one???

Someone care to comment ????

SRTILL8 07-27-2010 08:53 AM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
yo omar this is weird bro. i doubt its heat related since you say if you leave the hood open and etc.

this is def not it
- but this hood being open to start the car..reminds me how i trick my remote start to start the car while my hood is open.

wish ya the best bro-

White WK Swagga 07-27-2010 08:55 AM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
Did you try taking off neg terminal for a few min? IDK bro I wish I could let you use my warranty bro. I feel for ya!!!

DJ BoNiOmArIo 07-27-2010 09:27 AM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
Quote:

Originally Posted by SRTILLA (Post 242188)
yo omar this is weird bro. i doubt its heat related since you say if you leave the hood open and etc.

this is def not it- but this hood being open to start the car..reminds me how i trick my remote start to start the car while my hood is open.

wish ya the best bro-

Atilla, I should have been more specific sorry.

If I leave the hood open when the car is off then when I start it back up again with the hood closed it will not go into limp mode.

If I leave the hood closed when the car is off then it will go into limp mode.

IMHO it's about the heat escaping from the bay area and letting something cool suddenly and 10 minutes is not enough time for the engine nor the transmission to cool down enough

Quote:

Originally Posted by White WK Swagga (Post 242191)
Did you try taking off neg terminal for a few min? IDK bro I wish I could let you use my warranty bro. I feel for ya!!!

Thanks Nate much appreciated

I think I'm bout to cut my losses and get rid of this thing and get into something else cuz this is getting ridicilous on a student budget

DJ BoNiOmArIo 07-27-2010 09:47 AM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
55 views come on guys I really need the community help here ...

I have taken the car to the stealer and to a special transmission shop and they are baffled themselves as to what it is ... the stealer keeps on telling me I need to replace my solenoid and when I told them I did they accused me of doing it wrong LOL

Scottina06 07-27-2010 12:03 PM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
this trans temp sensor could be the problem. Do you know anything about it? Where its located? etc?

DJ BoNiOmArIo 07-27-2010 12:20 PM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
It got replaced along side with the circuit board I did that sits on top of the valve body, that does contain the temp sensor ... I checked again for the codes and now the temp sensor code is gone but the solenoid codes remain !!!

It's interesting because I clear the codes and P0762 pops up and I clear that one then P0763 pops up, it's like flipping a coin LOL

one thing I have noticed though that my engine bay gets unregularly HOT, what about any of yours? does it get to the point that you can't even touch the battery or the terminals? I tried to disconnect my battery terminal and was not even able to touch it

I am going to look for simple things such as fan ? or fuses ?

Scottina06 07-27-2010 12:29 PM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
maybe the tranny cooler? Does the 3.7's have those?

Scottina06 07-27-2010 12:29 PM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
have you checked your coolant? test your coolant and see what it tests out at

DJ BoNiOmArIo 07-27-2010 12:44 PM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
I will check on the coolant but when I had the scanner plugged in showing real time data the coolant was around 200 normal operating temp and the tranny at 400 LOL

I am planning on doing a coolant flush as part of the regular maintenance schedule this sunday

which can mean a short or low voltage due to resistance somewhere along the line

tranny fluid level is at correct levels and it did not smell burnt at all when the valve body was pulled

Scottina06 07-27-2010 12:46 PM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
I would test it with a cheap tester to see if it is normal. The sensor may be reading it incorrectly. Does the 3.7 have a tranny cooler?

DJ BoNiOmArIo 07-27-2010 12:54 PM

Re: 3.7L GC - Limp Mode P0762 P0763 NEED HELP !!!
 
I will check into that also it's still mind bobbing with the hood though LOL

I stand corrected yes it does come with one


All times are GMT -5. The time now is 01:33 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community