Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Just installed a srt8 exhaust on a 5.7 hemi ? (http://www.jeepgarage.org/f5/just-installed-a-srt8-exhaust-on-a-5-7-hemi-11548.html)

Shadohc 07-31-2010 10:24 PM

Just installed a srt8 exhaust on a 5.7 hemi ?
 
I just had my srt exhaust put on my 5.7 hemi well today while driving it the check engine light came on and is throwing 2 codes they are p013c and p0430 i have been doing alot of searching before i made this post is anyone having this issue or should i take it back to the exhaust shop and have them check for leaks or do i need a programmer to turn off the 02 sensor

Scottina06 07-31-2010 10:39 PM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
I would guess it has a leak....they shouldnt have been anywhere near the 02's

Shadohc 07-31-2010 10:53 PM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
i was doing alot of searching and read that i may need to replace 02 sensor. I am not sure if this is a exsisting problem from previous owner trust me i have fixed alot of problems will this code hurt my engine if i drive it back to the shop ?

Chaoul1 07-31-2010 11:02 PM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
Well if it's an O2 sensor, all it will do it burn the gas more. Call them up first and explain to them what has happened.

Scottina06 07-31-2010 11:10 PM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
have it checked for leaks. Or they coulda left it unplugged etc.

Shadohc 07-31-2010 11:12 PM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
both 02 sensors are there and they plugged a egt hole also i am leaning towards a leak i hope they fix it for me

Asativa 07-31-2010 11:18 PM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
Quote:

Originally Posted by Shadohc (Post 245213)
both 02 sensors are there and they plugged a egt hole also i am leaning towards a leak i hope they fix it for me

shadohc, where in md are u, i have a shop in camp springs and if the exhaust shop cant/wont help u, i can check the prob out for u no problem.. but ya they shouldnt have been anywhere near the o2s unless u changed up ur converter or anything before the converter.

andy

555ctsv 08-01-2010 08:51 AM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
I had a problem after having my tranny rebuilt. There are 3 O2 sensors all pretty close to each other. The tranny shop plugged the pre cat O2into the post cat harness and i had a code saying bank 2 was running lean and a couple other codes (although i dont recall the code #'s). With all 3 near each other it would not be a hard mistake to make. The drivers side post Cat and the passenger side pre cat wires are the closest to each other. Could be that simple.

Shadohc 08-01-2010 06:17 PM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
Update today I think I fixed my problem

I went over the exhaust today and snugged everything up reset the code and took it for a drive and the light came back on again i was only getting 10mpg local and 14 highway so i went to a auto parts store after i figured out which 02 to replace I picked up a bosch lifetime oe for 25.00 came home put that in and was not fun reset the code took it for a nice drive no code so far and 18mpg i think i might have it figured out fingers crossed thanks guys

Chaoul1 08-01-2010 06:49 PM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
Good Job Man! :thumbsup:

555ctsv 08-01-2010 07:06 PM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
Nice! I hope the light stays off for ya

Shadohc 08-02-2010 12:44 AM

Re: Just installed a srt8 exhaust on a 5.7 hemi ?
 
Well I think i spoke to soon i took the jeep out for a little while tonight and the problem came back again 2 codes P013C and P0430 the way i reset earlier today was unpluging the battery and let it sit would that get rid of code or would i need to have a scan tool to get rid of them i guess i am back to square one I also put a bottle of lucas tune up in a bottle before this happened


All times are GMT -5. The time now is 05:51 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community