Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (
-   Troubleshooting/Problems (
-   -   New member with '04 WJ w/problem (

cef911f1 08-11-2010 04:44 AM

New member with '04 WJ w/problem
Hello all,

I''m the proud owner of a sick 2004 Grand Cherokee Limited. It has the 4.7 V8.

It acts like it has a dead battery but the battery is charged. The starter solenoid clicks when the ignition is actuated but the engine will not turn over. The battery is new and the alternator and starter have both been tested and checked "good". All connections seem to be good and no wiring issues are evident. I'm stumped.

I was able to jump start it the first time it happened but I haven't been able to do even that since last Friday. Any suggestions would be appreciated.



SRTILL8 08-11-2010 08:29 AM

Re: New member with '04 WJ w/problem
hey, did you try using the search? go to advanced options on the search tab. i did this for you in the link... i typed in starter, and selected the cat WJ and i got a bunch of misc threads-

this question has been asked in a couple different threads. some similar to your issue some less or more etc. but gl.

DJ BoNiOmArIo 08-11-2010 09:06 AM

Re: New member with '04 WJ w/problem

White Chocolate 08-11-2010 09:09 AM

Re: New member with '04 WJ w/problem
Welcome hope everything works out

Chaoul1 08-11-2010 09:49 AM

Re: New member with '04 WJ w/problem
Make sure the Battery connections are nice and tight. Also look for corrosion!!!!!

SRTgirl 08-11-2010 11:47 PM

Re: New member with '04 WJ w/problem
:) Welcome to Jeep Garage :)

mrjaydeeone 08-12-2010 01:19 AM

Re: New member with '04 WJ w/problem
Welcome, hope it all gets worked out

TJXJWJ 08-16-2010 08:17 AM

Re: New member with '04 WJ w/problem
Depending who tested your starter...I'm not so sure I'd trust it's working. I had mine tested at Advanced and the fat azz at the counter didn't even know how to use the machine properly. Mine tested fine, but was actually not fine. Replacing the starter was the answer. I spent days searching for the problem too...figuring the test was correct and the starter was fine.

All times are GMT -5. The time now is 04:18 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2015, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community