Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   First Post NEED HELP! '99 WJ Crankshaft Position Sensor (http://www.jeepgarage.org/f203/first-post-need-help-99-wj-crankshaft-position-sensor-12153.html)

nwcw2001 08-22-2010 10:25 AM

First Post NEED HELP! '99 WJ Crankshaft Position Sensor
 
Hey guys I am having problems. I am in the middle of changing out my Crankshaft Position Sensor.

Taking out the starter---no problem.
Taking out the mounting bolt for the CKS ---No problem.
Taking out the CKS ---PROBLEM

The damn thing will spin freely but I can't get it to actually come out. Do you guys have any hints or tips on what I can do to unlodge the damn thing?

Thanks for any help.

John

nwcw2001 08-22-2010 11:12 AM

Re: First Post NEED HELP! '99 WJ Crankshaft Position Sensor
 
Just giving this a bump. I have the hood up and the wires disconnected. I need to get this fixed by this evening so I can go to work tomorrow. Any ideas are good ideas! Thanks guys

nwcw2001 08-22-2010 12:12 PM

Re: First Post NEED HELP! '99 WJ Crankshaft Position Sensor
 
NEVERMIND! I figured it out!

1 pair of channel locks +brute force = Unstuck sensor!

nwcw2001 08-22-2010 02:35 PM

Re: First Post NEED HELP! '99 WJ Crankshaft Position Sensor
 
OK new issue. The CKS is in and it still wont start. I am getting an P0340 now.

Will the CKS going out kill my CPS?

Chaoul1 08-22-2010 06:11 PM

Re: First Post NEED HELP! '99 WJ Crankshaft Position Sensor
 
Check which code it is first! I don't have a code chart. Sorry.

straty1987 08-22-2010 06:23 PM

Re: First Post NEED HELP! '99 WJ Crankshaft Position Sensor
 
http://www.obd-codes.com/p0340

nwcw2001 08-22-2010 07:42 PM

Re: First Post NEED HELP! '99 WJ Crankshaft Position Sensor
 
I am pulling a P0340 which is the Camshaft Sensor now. I have changed it out but I am still getting the code. Could it be that it's not a OEM sensor? I am about to blow this thing up.

TJXJWJ 08-22-2010 09:17 PM

Re: First Post NEED HELP! '99 WJ Crankshaft Position Sensor
 
Did you get this figured out? Sometimes you need to reset the computer by disconnecting the battery for a few minutes.

You may also want to follow the harness for the sensor up and check the wires. Make sure nothing is chewed up, fried, melted. I burnt some wires once because the zip tie holding them broke and the wires got too close to the manifold. It may not have ever been the sensor from the beginning...it could be the wiring associated with it.


All times are GMT -5. The time now is 04:58 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community