Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Performance Modifications (http://www.jeepgarage.org/f6/)
-   -   Magnaflow Catback Installed - Slight Issue with Resonator (http://www.jeepgarage.org/f6/magnaflow-catback-installed-slight-issue-with-resonator-12421.html)

HemiDawg 08-30-2010 03:05 PM

Magnaflow Catback Installed - Slight Issue with Resonator
 
After sitting in the basement for almost 6 months (the Magnaflow, not me :D), I FINALLY got a chance this weekend to install my Magnaflow catback. Took about 3 hours to install - had issue with one of the bolts on the OEM muffler - there are no heads on the studs and I ended up breaking one of them loose from the weld, so after much time trying to unbolt it, I finally had to cut the bolt out. Magnaflow install was pretty straightforward, although those dang rubber hangers are a beotch to get loose.

Here is my issue. After installing the MF and taking it for a drive, I started getting a terrible rattling noise in the rear (the GC's, not mine :D). It was late, so the next morning I got back under the GC and made sure everything was tight. Took it for another romp fest and the rattle was still there. Figured out that although I am using the factory hangers as the instructions stated to do, the resonator hangs less than a 1/4 inch lower than the brace that holds the rear rubber hanger (behind rear bumper). Therefore, when driving, the resonator is vibrating up and hitting that brace and causing the noise.

Is this common?? Anyone else have this issue??

As a temporary fix, I took some small squares of Dynamat (kind with foil side) and stuck them to one another to make a thick block and stuck it between the brace and the resonator (sticky side on the brace) - seemed to take care of the issue for now, but not sure how long it will last with the heat. Anyone else have any suggestions for a permanent fix??

As far as the system itself, I am very happy with the sound. Nice rubble on startup, nice roar at WOT. Seems like it has a little more takeoff power from stand-still, but that may just be in my head.

yousmellfunnytoo 09-01-2010 10:20 AM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
I dont have a reso, but mine was rattling too. Check all the clamps, and make sure bolts arent hitting anything too

I also put on some header wrap in a couple of places, just to avoid the rattle, and to prevent a couple of lines from being melted by the pipe.

HemiDawg 09-01-2010 01:52 PM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
Thanks for the input. I know exactly where my vibration is coming from - all other connections are TIGHT!! I am thinking the pipe to the resonator needs to be shortened by a few inches in order to pull the resonator forward some so it will clear the brace holding the rear hanger.

It is going to a custom muffler shop tomorrow to have them take a look at it - may have them go ahead and weld the pipe connection together.

kevin06vino 09-01-2010 09:46 PM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
Quote:

Originally Posted by HemiDawg (Post 261744)
Thanks for the input. I know exactly where my vibration is coming from - all other connections are TIGHT!! I am thinking the pipe to the resonator needs to be shortened by a few inches in order to pull the resonator forward some so it will clear the brace holding the rear hanger.

It is going to a custom muffler shop tomorrow to have them take a look at it - may have them go ahead and weld the pipe connection together.

I wonder if there is something different between the 2010 and my 2005. I haven't had any issues with the resonator on my Magnaflow catback.

HemiDawg 09-07-2010 08:56 AM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
Ends up the pipe was a little too long between the muffler and the resonator. Custom exhaust shop cut off the resonator and removed about 1/2 inch of pipe and welded back on. Resonator now hangs behind the factory brace instead of under it - problem solved.

Shop owner did mention he has been a long-time installer of Magnaflow and he has noticed in the past few years that their quality/ fit is not what it used to be.

White Chocolate 09-14-2010 08:20 PM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
Hey bro would you mind postin a nice video....youtube videos suck from what i found

HemiDawg 09-15-2010 10:12 AM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
Quote:

Originally Posted by KlutcH (Post 268126)
Hey bro would you mind postin a nice video....youtube videos suck from what i found

I'll see what I can do - just got a new Sony Bloggie (similar to Flip video camera) for the baby and have not had a chance to use it.

White Chocolate 09-15-2010 10:37 AM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
I'd like to hear a couple good videos of it...especially from in the cab, and a little rev.

I found some youtube videos, but yours might better my decision. Im thinkin about going with magnaflow catback as well

HemiDawg 09-15-2010 02:59 PM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
Will do, just keep in mind I do have an aFe Stage 2 intake which also contributes to the sound, so it won't be just the exhaust.

I am meeting a few friends tomorrow to play volleyball - I will have them help me film some clips.

White Chocolate 09-15-2010 03:45 PM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
Yeah thats understandable, however I also have an airaid, so it will be very similair in a way

alretired 09-16-2010 08:58 AM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
Just installed a Magnaflow Catback on my 2009 Limited w/5.7 Hemi. No issues with clearance nor any vibration at all. Fit was really good and provides a great sound with little or no resonance. Slight bit of it when in MDS mode.

White Chocolate 09-16-2010 08:01 PM

Re: Magnaflow Catback Installed - Slight Issue with Resonator
 
Quote:

Originally Posted by alretired (Post 268917)
Just installed a Magnaflow Catback on my 2009 Limited w/5.7 Hemi. No issues with clearance nor any vibration at all. Fit was really good and provides a great sound with little or no resonance. Slight bit of it when in MDS mode.

Can you post a vid please


All times are GMT -5. The time now is 10:07 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community