Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   06 Hemi Using/Losing Oil (http://www.jeepgarage.org/f5/06-hemi-using-losing-oil-12515.html)

06HemiLtd 09-03-2010 09:41 AM

06 Hemi Using/Losing Oil
 
i have an 06 limited with hemi that i bought brand new(was waiting at dealership when truck arrived). i did 1st oil change at 1k miles and switched to full synthetic and have done it on the 5k mark ever since. i'm now at 45k. everytime, the oil level has always been right where it's supposed to be. i changed it 2 days ago and i was over 1 qt low. any ideas why.

gc4x4 09-03-2010 06:17 PM

Re: 06 Hemi Using/Losing Oil
 
Quote:

Originally Posted by 06HemiLtd (Post 262635)
i have an 06 limited with hemi that i bought brand new(was waiting at dealership when truck arrived). i did 1st oil change at 1k miles and switched to full synthetic and have done it on the 5k mark ever since. i'm now at 45k. everytime, the oil level has always been right where it's supposed to be. i changed it 2 days ago and i was over 1 qt low. any ideas why.

Do you do any towing? long road trips? In my experience all engines burn a small amount of oil, its mostly an noticeable amount, however if the oil hasn't been changed regularly or the vehicle tows heavy loads, then you may notice a lower oil level due to normal combustion. Another thought is that you may have an oil leak somewhere, check for wetness under the engine and also pull a spark plug to check if its oil coated, an oil coating means that you may need internal engine repair, like valve seals. Good luck

Chaoul1 09-03-2010 08:11 PM

Re: 06 Hemi Using/Losing Oil
 
Get a Oil Catch Can! That will solve your problem! First make sure the Head Gasket isn't bad. If you think your Jeep is burning oil check from the exhaust and see if there is any Blue Smoke when you start it up.

An Oil Catch Can go to BilletTech

jeepgcoman 09-03-2010 09:15 PM

Re: 06 Hemi Using/Losing Oil
 
Chaoul1 is right about the catch can. When is the last time you changed your PCV valve? If it's not working properly it'll suck oil right through it and into the intake manifold. Take your intake tube off, and with the engine and key off, manually open the throttle body butterfly. Shine a light in and look at the back side of the butterfly, and the plenum (behind the butterfly) area. If you're all gunked up and/or there is evidence of oil (film or puddling) in the plenum, your PCV is bad. A properly serviced catch can resolves the mess in the intake/throttle body, but does not negate the need to change the valve.

Mike_Levy 09-04-2010 03:02 AM

Re: 06 Hemi Using/Losing Oil
 
EVen if the PCV is working theres gonna be oil in the manifold. Hemis suck oil. Thats just the way it is. I can count on adding at least a quart every 3k miles.

06HemiLtd 09-04-2010 05:43 AM

Re: 06 Hemi Using/Losing Oil
 
thanks for the replies. i bought a 1800 lb pop-up camper this summer and have towed it 4 times but only 100 miles total. no hills. never over 55mph. this was the 1st time i've towed with the jeep. i will have to look into the catch can.

Milous 09-04-2010 06:02 AM

Re: 06 Hemi Using/Losing Oil
 
Quote:

Originally Posted by Mike_Levy (Post 262986)
...Hemis suck oil. Thats just the way it is. I can count on adding at least a quart every 3k miles.

How many miles on your rig? Has it done this since it was new?

jeepgcoman 09-04-2010 10:17 AM

Re: 06 Hemi Using/Losing Oil
 
My Hemi LX (bought new) doesn't use a drop between 6000 mile interval changes, but my Hemi WK (bought used) appears to be using some. So far, on this cycle (about 2500 miles in), the dipstick is down about 1/8 in. That may end up around a quart in 6000 miles.

06HemiLtd 09-04-2010 10:33 AM

Re: 06 Hemi Using/Losing Oil
 
like i said, i've owned my wk for 5 years now and it's never used any oil at all. i did notice some sludge around the fill neck/cap and a blue powder. thinking about trying some z-max or engine restore.

Mike_Levy 09-04-2010 01:50 PM

Re: 06 Hemi Using/Losing Oil
 
Quote:

Originally Posted by Milous (Post 262995)
How many miles on your rig? Has it done this since it was new?

22k, and yes, its done it since new (I bought it with 3850). My 300 SRT8 did the same thing.

Walt 09-04-2010 09:42 PM

Re: 06 Hemi Using/Losing Oil
 
Quote:

Originally Posted by Milous (Post 262995)
How many miles on your rig? Has it done this since it was new?

My HEMI used more on dino oil than it does on full synthetic. I used 3 qts in 6,000 mi on dino oil; now use 1.5-2 qts between oil changes on synthetic.

Has done this since new (now at 50,500 miles). I complained to dealer about what I believe is excessive consumption for a new engine. Chrysler replied that anything up to 1-qt per 1,000 miles is "within normal limits".

Just checked the PCV valve internals and o-rings and it's clean and normal.

Milous 09-05-2010 02:08 AM

Re: 06 Hemi Using/Losing Oil
 
Quote:

Originally Posted by Mike_Levy (Post 263076)
22k, and yes, its done it since new (I bought it with 3850). My 300 SRT8 did the same thing.

Oil consumption seems to vary a lot. Guess I have been fortunate, my '08 SRT is pushing 20k and I've never added oil between changes. Same with my '06 SRT when I had it.


All times are GMT -5. The time now is 10:05 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community