Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   P0750 ?? (http://www.jeepgarage.org/f5/p0750-12680.html)

sdionne 09-08-2010 07:08 PM

P0750 ??
 
On my way home today I got two DTC P0700, P0750. I have looked online every where and have yet to find a straight answer as to what could be causing these codes. Anybody know what the issue could be??

2005 Limited 5.7 w/ 5-45RFE Trans

Scottina06 09-08-2010 08:03 PM

Re: P0750 ??
 
tranny control fault and shift solenoid malfunction...reset your pcm and see if they come back first....

Redrubicon2004 09-08-2010 08:17 PM

Re: P0750 ??
 
Have you had any shifting troubles? I got those codes a few weeks ago and it ended up dropping into 3rd gear (limp mode) Dont plan any long trips until you get a chance to test things out.

I had to replace my transmission shift module.

sdionne 09-08-2010 08:36 PM

Re: P0750 ??
 
i pulled the battery tuesday nite to reset everything and they came back up this afternoon on my way home, when the codes come up it goes in to (limp mode) and stays in 3rd gear.

Redrubicon2004 09-08-2010 08:48 PM

Re: P0750 ??
 
Sounds like you need a new trans shift module. Try checking the connection on the side of the trans. Make sure its not loose or pull it apart and make sure the contacts are clean. Its about a 1.5" square connector on the drivers side of the trans. Its just above the front drive shaft. Its kind of hard to get your hands on.

I got mine from a jeep dealer for $325. This is the cheapest I found on the net. http://cgi.ebay.com/ebaymotors/ws/eB...d=330372435837

Scottina06 09-08-2010 09:01 PM

Re: P0750 ??
 
^^^^^good info

sdionne 09-08-2010 09:16 PM

Re: P0750 ??
 
how hard is it to replace trans shift module

Redrubicon2004 09-08-2010 10:31 PM

Re: P0750 ??
 
Not bad. It took me a couple hours. I think the total project with fluid was around $400. The dealer quoted me $850

1. Pull and drain trans pan
2. Disconnect main harness that plugs into trans. (I had to pull the front drive shaft to get to it)
3. Loosen the bolts that hold the valve body in the trans
4. Carefully lower the valve body
5. Unbolt the shift module from the valve body
6. Reverse process :D

Start on page 103

http://www.hotrodlane.cc/New%20HEMI%...mi%20trans.pdf

The whole valve body and the module come out together and no loose parts to worry about. Just drop it out, replace the module and replace the valve body.

Make sure you change both filters while you are in there. One looks like an oil filter, the other looks like a typical trans filter

sdionne 09-09-2010 07:58 AM

Re: P0750 ??
 
Thanks bro, looks like i have a weekend project now

attilahooper 01-02-2011 02:13 PM

Re: P0750 ??
 
How in the hell do you get yer hands on that bloody connector ? I was stuck in 3rd, dicked-around with the gear shift mech to no avail. Then decided to pull codes, doh, I shoulda done that first.

anyway, wiggled the 25 pack connector, or whatever they call that thing on the trans. Sure enough, back into D. dayum. So, Any words on pulling the driveshaft ??? just the bolts on the front to the transfer case ??? thx in advance

konarider94 08-30-2011 08:33 PM

Re: P0750 ??
 
this happened to me on the way home today(P0700 and P0750). it has since gone back to normal and the CEL went away. I drove around for 30-40min without any issues. I also get an intermittent CEL due to the secondary O2 sensor in bank 2. Im thinking bad wiring connections but we will see, i guess i have to get motivated and check out these connectors. Just wanted to say thanks to those that provided info in this thread.

konarider94 09-01-2011 10:08 PM

Re: P0750 ??
 
im pretty convinced its the solenoid pack. i will be purchasing one in the morning most likely. its not a bad connection anywhere, every time it goes into limp mode if i shut the vehicle off and then start it again it will drive for some random amount of time before going back in to limp mode. if it was a bad connection i would think this would not fix the issue temporarily every time.

i already have some wix transmission filters sitting around and 2 gallons of amsoil transmission fluid. anyone strongly opposed to amsoil or wix filters?

im thinking i might as well install the transgo shift kit if i have the valve body out.

ill provide updates on my progress and welcome any thoughts or opinions in the mean time.


All times are GMT -5. The time now is 06:37 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community