Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Export & Diesel Powered Jeep Models (http://www.jeepgarage.org/f79/)
-   -   Cold start misfire (http://www.jeepgarage.org/f79/cold-start-misfire-12694.html)

carldieselgc 09-09-2010 08:14 AM

Cold start misfire
 
My 2007 3.0 Diesel has developed a misfire on a cold start. This has happened only about 5 or 6 times in the last 2 months out of about 100 cold start ups. I had a glow plug for the # 1 cyl. replaced and that corrected the check engine light, but still sometimes getting the misfire without a warning light. Any suggestions ? My mechanic doesn't want to just start replcing parts at my expense until he knows for sure. Also on a scan an error code cam up for a misfire on clyl. #6 and a cam possitioning sensor error, but he says it appears to to be o.k. now.

Spider-One 09-10-2010 04:16 PM

Re: Cold start misfire
 
Might be the cam position sensor. Pretty sure they're known to go bad. I don't think it's too expensive and pretty simple to replace. Cheap insurance anyways

bessniak 10-08-2011 04:53 PM

Re: Cold start misfire
 
my friend own 2007 gc 3.0 crd in cold days he has this trouble to but there s a good chance first switch ingnition on and wait 5 seconds then turn ignition of , turn it on again and wait 5 seconds ,turn of , in the third time wait 5 seconds then start the engine up it will start faster and without idling to much ! this process heat engine block 3 times

TJcust 10-20-2011 11:49 AM

Re: Cold start misfire
 
^^ that would only turn the glow plugs on and off.

Turn the key to the on position for 10-15 seconds before you turn fully to the start position...If your not already doing that.


All times are GMT -5. The time now is 10:00 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community