Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Still having suspension problems!!! (http://www.jeepgarage.org/f5/still-having-suspension-problems-13531.html)

JRsmoothee 10-02-2010 10:07 PM

Still having suspension problems!!!
 
so i have been having a horrible popping clunking sound coming from my front suspension ever since i got my new springs and sruts installed, took it to the dealer to have them check it out. They said the shop that installed them did not tighten anything up and i was basically ridding on my tires (whatever thats suppose to mean) but anyway they tightened everything up and i still have the same horrible clunking, it wasnt very bad when i first got it back from the dealer, but tonight i drove it and it was bad!!
anything i should tell them to look at when i take it back to them next week.......and my rear right tire alignment dont seem right!! and LOL at the mechanics spelling f*cking retards

http://i13.photobucket.com/albums/a2...e/scan0001.jpg
http://i13.photobucket.com/albums/a2...e/scan0002.jpg

JRsmoothee 10-03-2010 12:06 PM

Re: Still having suspension problems!!!
 
anybody???

Harrison@Stage6 10-03-2010 12:16 PM

Re: Still having suspension problems!!!
 
Raddle?!?! That's comical. Did they check the ball joint to make sure it's not jacked? How many miles are on your Jeep? What suspension did you put in?

JRsmoothee 10-03-2010 12:20 PM

Re: Still having suspension problems!!!
 
roughly 7000 miles on her still brand new, wk bilstiens with wk eibachs......i dont know if they checked the balljionts or strut mounts and all that stuff my g/f took it in for me, as i have 0 time during the day to get anything taken car of

robpp 10-03-2010 12:25 PM

Re: Still having suspension problems!!!
 
if they didnt yank the strut all the way out, i would suspect the top nut wasnt tightened all the way down the fiorst time. and ai dont think you could do it withoutn the strut out.

plus on their bill, it says it still needs something?? third item??

JRsmoothee 10-03-2010 12:29 PM

Re: Still having suspension problems!!!
 
yeah i dont think they even looked at the strut or touched it...... as for the 3) on my sheet they suggested taken it back to the shop that installed them, but im not letting them guys touch my jeep anymore, they were rude and obviously didnt do what they were suppose to do

Quote:

Originally Posted by robpp (Post 278559)
if they didnt yank the strut all the way out, i would suspect the top nut wasnt tightened all the way down the fiorst time. and ai dont think you could do it withoutn the strut out.

plus on their bill, it says it still needs something?? third item??


JRsmoothee 10-03-2010 12:32 PM

Re: Still having suspension problems!!!
 
what about the aligment specs on my rear right tire??? that dont seem right

DJ BoNiOmArIo 10-03-2010 03:18 PM

Re: Still having suspension problems!!!
 
your allignment is not that off plus for the rear there's not much you can except for the toe ... however the clunk noise might be from what Rob suggested life your hood up and check where the strut mount is and see if those bolts are tight enough ...

Also it can be your sway bar bushings or even the links ... however I do really suggest that you have someone take it all apart the strut and shocks and re install them properly using the proper torque specifications

that always helps

other than that can't think of much ... there is one more thing though ... the upper control arm is in the way when your installing the front struts they might have messed with that

JRsmoothee 10-03-2010 03:29 PM

Re: Still having suspension problems!!!
 
yeah thanks guys..... im gonna hve the dealer rip the struts and springs out and properly reinstall them, ive spent too much damn money on all this supension parts/labor....i wish i would have just kept it stock

DJ BoNiOmArIo 10-03-2010 03:54 PM

Re: Still having suspension problems!!!
 
Quote:

Originally Posted by JRsmoothee (Post 278614)
yeah thanks guys..... im gonna hve the dealer rip the struts and springs out and properly reinstall them, ive spent too much damn money on all this supension parts/labor....i wish i would have just kept it stock

I've said that a couple of times as well ... trust me it happens ... quick question have you upgraded your sway bars?

If you haven't it's a must mine are shot and the car is not stable anymore so would advise to do that as well

JRsmoothee 10-03-2010 04:06 PM

Re: Still having suspension problems!!!
 
no i havent upgraded my sways.....i dont think mine are shot i've got roughly 7000 miles on my jeep, i would consider that still brand new

DJ BoNiOmArIo 10-03-2010 04:08 PM

Re: Still having suspension problems!!!
 
yeah that is still considerably new ... I do advise it down the road though ... hope all your troubles are worked out for you


All times are GMT -5. The time now is 12:39 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community