Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   99 GJ 4.7 will not stay running and pings when try to accelerate slow (http://www.jeepgarage.org/f196/99-gj-4-7-will-not-stay-running-and-pings-when-try-to-accelerate-slow-14068.html)

pagokid 10-17-2010 08:41 PM

99 GJ 4.7 will not stay running and pings when try to accelerate slow
 
Put all new sensors and rebuild motor but won't stay running when idles drops below 1000 rpm. When I shift in gear it will stay runing but up and down at idles, when tries to accelerate it backfires and pings hard like a bad flow meter. Disconnected the Cat.Con. and no change. Vacuum is good and all new parts but still doesn't want to run right, my mechanic told me he crossed the battery cable when he put the battery in, would that cause any damage to the PCM or other controll units. Anybody out there that can help, I don't know what to do next. Thanks

Scottina06 10-17-2010 08:46 PM

Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow
 
sounds like a pcm issue....but who knows really without being in the Jeep. Any codes or anything?

pagokid 10-17-2010 11:38 PM

Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow
 
the codes keeps coming up that 3and4 cyl.are mis firing. When accelerates to about 1500-2000 rpm you can feel the misfire, but when you let off the throttle the engine comes down to idle mode and runs pretty good for about 10 seconds the shuts off. But when I put it gear the engine will stay idle and diesels up and down.

Scottina06 10-17-2010 11:48 PM

Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow
 
could be a crank or cam sensor or the tps.....hard to say

Chuck 10-18-2010 06:28 AM

Quote:

Originally Posted by Scottina06 (Post 286381)
could be a crank or cam sensor or the tps.....hard to say

I was just thinking that. Have you already replaced these sensors?

Frango100 10-18-2010 03:17 PM

Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow
 
Idling problems many times are caused by the IAC stepper motor pintle or air passage, which gets dirty with oil and dust particles.
If the mechanic who installed the battery, also did the engine rebuild, i would cross my fingers...........................and first of all change to an other one:D
Is the engine completely rebuild and do you know why this was done?
A misfire is detected by the PCM by a small deceleration. This can be caused by ignition problem, fuel supply problem (fuel injector) or low compression in related cylinder(s).

scjeep4.7HO 10-18-2010 03:40 PM

Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow
 
If it's in those 2 cylinders (3 &4) make sure the coils and/or fuel injectors wires haven't been swapped during install. Pull and check your spark plugs in those cylinders if wires are correct.

Frango100 10-18-2010 05:51 PM

Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow
 
Isn't coil 3 on the left bank and coil 4 on the right bank?

Escape 10-19-2010 09:31 AM

Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow
 
3 is drivers side. 4 is passenger side on a US vehicle.

pagokid 10-25-2010 02:09 PM

Re: 99 GJ 4.7 will not stay running and pings when try to accelerate slow
 
I decided to check the voltage on the crankshaft and it only shows .50 volts not even close to what it supposed to be at 5.0 volts. So I send the PCM out to be check and repair, hopefully this will solve the problem, I will let you know what happens.


All times are GMT -5. The time now is 03:22 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community