Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   Engine Died Fast (http://www.jeepgarage.org/f77/engine-died-fast-1413.html)

JeepWK05 07-14-2009 05:48 PM

Engine Died Fast
 
I pulled out of my driveway, drove about 1/4 mile, stopped... and then my engine stalled.. died? on me. Started right back up but why did it do this. First time this has happened since i bought the car this year. I would like to figure out the reason for this before it gets worse.

Vitals:
Model: 2005 w/ 4.7 V8
Miles: 51,000
Temperature: 65*
Oil: Changed ~750 miles ago

Anyone have a clue why it would have done this?

LTrainGC 07-14-2009 05:51 PM

Re: Engine Died Fast
 
I'm assuming the CEL didnt come on?

mjl2610 07-14-2009 05:56 PM

Re: Engine Died Fast
 
Do the "key dance" and check for codes if possible?

Scottina06 07-14-2009 06:01 PM

Re: Engine Died Fast
 
believe it or not....this is a transmission programming thing. Get the TSB done for the 4.7 V8's.....

Marlin 07-14-2009 07:19 PM

Re: Engine Died Fast
 
If thats a confirmed TSB guys can we add it to the "WK common faults and issues" thread? Please?

JeepWK05 07-14-2009 07:24 PM

Re: Engine Died Fast
 
There was no CEL.

Oh, i forgot to check for codes... too late now. If you go to the dealer for the TSB you have to pay for labor correct?

Scott, Could you provide me with the specific code. I check WKjeeps and there is a lot of TSB's for the transmission.

06SRT8300C 07-14-2009 08:05 PM

Re: Engine Died Fast
 
Mine stalls alot and wont start for like 3-5 min:D

NHWK05 07-14-2009 09:06 PM

Re: Engine Died Fast
 
Go add half a quart of ATF+4 to your tranny. Mine did that too and it idles weird and i added the tranny fluid and presto its smooth as butter now.

---------- Post added at 10:06 PM ---------- Previous post was at 10:06 PM ----------

Quote:

Originally Posted by 08HEMIJEEP (Post 33384)
Mine stalls alot and wont start for like 3-5 min:D


Thats your crank position sensor.

JeepWK05 07-14-2009 11:33 PM

Re: Engine Died Fast
 
Quote:

Originally Posted by NHWK05 (Post 33407)
Go add half a quart of ATF+4 to your tranny. Mine did that too and it idles weird and i added the tranny fluid and presto its smooth as butter now.

It was just serviced you sure i need more fluids? Even put in a whole new front differential, whopping $3000 (warranty :thumbsup:).

NHWK05 07-15-2009 06:58 AM

Re: Engine Died Fast
 
Yes, Over fill the tranny by 1/2 a quart and see what happens. 99% of the funny idle/stalling issues in WKs are tranny related. Its either this or a computer issue.

jhawk 07-15-2009 08:11 AM

Re: Engine Died Fast
 
I had an 05 rocky 4.7L. It did this a few times when I had it. Never happenned to my 5.7L limited though.

NHWK05 07-15-2009 08:16 AM

Re: Engine Died Fast
 
Give it a try, it wont hurt anything if it does not work.


All times are GMT -5. The time now is 05:15 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community