Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   07 WK - Right brake/running light not working?? (http://www.jeepgarage.org/f5/07-wk-right-brake-running-light-not-working-14199.html)

TheAngryMinnow 10-20-2010 06:30 PM

07 WK - Right brake/running light not working??
 
Fuses are fine, bulb is OK, reverse light works fine.

I've had the rear bumper off for paint a few times in the last month (they didn't do it right at first) and they DID mess up my rear park assist system (have to take it to chrysler on their dime for repair/adjustment) and now the right tail light is out (at first it would go out every other time i drove the car) so I'm assuming this is wiring....maybe near the junction on the left side where it meets up with the main line for the left tail and rear park assist system?

Is there anything I can check on my own prior to taking it to Chrysler? Got pulled over for it tonight and the cop was nice enough to just let me know it was out.:cool:

SvenskaJeepGuy 10-20-2010 10:24 PM

Re: 07 WK - Right brake/running light not working??
 
check the harness between the light and the vehicle. mine crapped out on me once.

TheAngryMinnow 10-20-2010 11:00 PM

Re: 07 WK - Right brake/running light not working??
 
Is that the harness that runs from the light to the split in the wiring on the left side where the left light ties in?

SvenskaJeepGuy 10-20-2010 11:09 PM

Re: 07 WK - Right brake/running light not working??
 
yes, where you plug the tail light into the vehicle. mine wasnt staying connected tight.


All times are GMT -5. The time now is 10:16 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community