Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio, Video, Navigation & Electronic Modifications (http://www.jeepgarage.org/f50/)
-   -   install problems.... (http://www.jeepgarage.org/f50/install-problems-14315.html)

jdcollins86 10-23-2010 03:37 PM

install problems....
 
hey guys
the other day i had my sub installed... it sounds good but a few problems. the shop that did it is a bunch of idiots and for some reason when the stereo is off i can still hear the bass coming out of the sub, and if i turn down the volume on the radio down the bass still bumps.. and if i my ipod playing i can turn the ipod down and it turns down the bass???
my jeep has the factory boston set up with the touch screen.. i wanna save a few bucks and do it my self, and not take it back to shop that did the install. does any one have a wire digram ??? thanks

robpp 10-23-2010 04:51 PM

Re: install problems....
 
wkjeeps has a diagram to show how the KICKER sub is installed. it taps into one front door speaker for the bass; ground under the dash, power wire to the fuse box post.

jdcollins86 10-23-2010 08:24 PM

Re: install problems....
 
thanks rob

Unholyskorn86 10-23-2010 08:26 PM

Re: install problems....
 
If they did it why not bring it back and have them fix it for free?

jdcollins86 10-24-2010 05:23 AM

Re: install problems....
 
they are just retards...i dont want deal with them

robpp 10-24-2010 11:59 AM

Re: install problems....
 
so what did they use to install it and what exactly are the components.

like what amp, what sub, how did they try to connect it. did they give you one of them gain knob things.

post up as much you know than peeps can help out. we arent all experts but a few have done this.




do you have a heated work area ??? LOL

Chuck 10-24-2010 03:02 PM

Re: install problems....
 
To be honest, I would take it back to the shop. You paid for them to do it properly and its not working so I would take it back and tell them whats up. But x2 on what Rob said, what did you end up installing? Did you purchase any harnesses or special adapters?

JDubya 10-29-2010 05:49 PM

Re: install problems....
 
Quote:

Originally Posted by Chuck (Post 289885)
To be honest, I would take it back to the shop. You paid for them to do it properly and its not working so I would take it back and tell them whats up.

Quote:

Originally Posted by jdcollins86 (Post 289731)
they are just retards...i dont want deal with them

Follow your instincts. I was in a similar situation with one of my previous cars. I had a shop install a 2-way pager alarm. It started acting up so I took it to the shop. They guy that installed it wasn't there and the new guy that looked at it was clueless. When we first started talking he said to pop the hood and try to start it. I said it wont because of the safety hood switch (it was a 5-speed and required very specific actions for it to remote start). He said it would so I tried and of course, it didn't start. I should've left right there but I didn't. It was a bit of a drive to get there so I gave him the benefit of the doubt. Ultimately, he ended up putting 2 dents around my roof/c-pillar "testing" the shock sensor. This MFer got me heated and the manager wouldn't do shit about it bc his dumbass employee said the dents were there. No, I saw his fist make the dents. He's lucky my fists didn't dent his face...

Sorry for the rant lol but sometimes it's better to cut your loses and take care of it yourself.

DGoral31 10-29-2010 05:54 PM

Re: install problems....
 
i would take it back also, tell them the issues you are having they should be more than happy to fix it, its probably easy and quick... if you do it and F things up, then for sure they will charge you or say it was your fault for messing with it.

where did you mount the sub? any pics?

2005JGC 11-17-2010 03:52 PM

Re: install problems....
 
It kinda sounds like the gain is up too high... mess with the levels on the amp itself.


All times are GMT -5. The time now is 04:46 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community