Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   new engine sounds like is not advancing (http://www.jeepgarage.org/f77/new-engine-sounds-like-is-not-advancing-14326.html)

pagokid 10-23-2010 10:03 PM

new engine sounds like is not advancing
 
I put a new motor in my 99GJ and replaced every sensor their is, even had a rebuild PCM installed but still dies a idle.It pos and pings when I tried to accellerate from idle, smell very rich out of the exhaust and misfiring like is out of time. Tried everything and the codes keep saying the coils are not functioning right, Sometimes it will starts anr run for about 10 seconds really nice but then it shuts it self off. Is ther a possibility the crank ring could be bad or bend, its got 16 teeth like the old one. Sometimes when I start it, it locks up like the timing is advanced then eventually turns over and fires but it backfires out of the throttle body. Anybody out ther with any information would be great, I don't know what else to do. I also check the timing chain and it's is right.

Chaoul1 10-23-2010 10:34 PM

Re: new engine sounds like is not advancing
 
You sure it's not the O2 Sensors? Make sure you get OEM O2 Sensors.

Scottina06 10-23-2010 11:11 PM

Re: new engine sounds like is not advancing
 
as i started reading.....I was gonna suggest the tone ring.......

Where did you get the pcm and are you sure its correct/good?

pagokid 10-24-2010 11:56 AM

Re: new engine sounds like is not advancing
 
I order the pcm from autocomputer in Florida, I've used them in the past and never had any problems with their products. The O2 sensors were from napa (bocsh) I don't think the O2 would keep the engine from advancing. The plugs gets fouled pretty fast after I put in new plugs.

gojrracing 10-31-2010 05:41 AM

Re: new engine sounds like is not advancing
 
new and used engines Hello pagokid, how much did it cost you with that pcm?


All times are GMT -5. The time now is 06:56 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community