Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   immediate help needed!! (http://www.jeepgarage.org/f5/immediate-help-needed-14869.html)

stealth32 11-07-2010 02:39 PM

immediate help needed!!
 
so today i was heading back home and i went over a bad bump. My e brake light immediately turned on while i was driving. Thinking it was a little computer mistake i proceded to keep driving and it then went away. Everything was fine till i braked and it felt like the abs kicked in. Only when i had pressed the brake slowly it felt like i was braking in snow. It was constent though it would happen then not for a while then come back. Suddenly after the second time that happend my abs, eps, and traction light came on all at the same time. This is when i bugged out. I immediatly turned off the car when i pulled in. I turned the car back on again and it still was on. I drove it to the dealership and the abs was doing it constent now with the braking. As soon as i pulled into the dealership all the lights tunered off! Dealership told me its because i have aftermarket rims and that is causing everything to bug out. I have aftermarket srt8 rims in black. Not the real ones a replica. Anyways thats what the dealership told me. The only other thing i have are hids. No other mods. After i drove it off from the dealership everything was fine the abs wasnt kicking in......Till late that night lights came on again then turned off 5mins later. The abs has kicked in twice already since i got it back. God it feels like my rotors getting hit. Could it be because the rims are to big and the brakes might need to be changed. Ive been driving with the rims on for about 5,000 miles on them and the only light that turned on was tbs sensor which wasnt a biggie. It only has 11,000 miles on it its a 2009. Any help guys would be great i will be changing my tires back to stock ones since winters coming up and its getting to cold here. Maybe ill see what happens with the stock ones on. BTW dealership charged me 120 for ''looking''

DJ BoNiOmArIo 11-07-2010 02:43 PM

Re: immediate help needed!!
 
Well first off the dealership people in most cases are morons and the SRT reps should not cause any problems like that ... At this point it can be something electrical or your e-brake line causing some problems ... I would disconnect the battery terminals let it reset the pcm see if that helps if not hope someone else can chime in for more info

stealth32 11-07-2010 02:46 PM

Re: immediate help needed!!
 
well i installed the hids my self and i have a ground on the postive and a negative ground near the head light. You think my negavtive or postive ground is causing this i even disconneted my hids and the lights were still on so idk

stealth32 11-07-2010 02:47 PM

Re: immediate help needed!!
 
disconnect both ?and for how long

robpp 11-07-2010 02:48 PM

Re: immediate help needed!!
 
most of the stuff is the same srt8/wk except for the brembos. like omar said the dealer is FULL of idiots. the ABS sensors are the same. Go look at all your wheels where the abs sensors plug in. mayabe whil the jeep is running. shake the wires while someon sits and monitors the dash.

stealth32 11-07-2010 02:49 PM

Re: immediate help needed!!
 
where is the abs senor located

robpp 11-07-2010 02:54 PM

Re: immediate help needed!!
 
DESCRIPTION
A wheel speed sensor is used at each wheel. The front sensors are mounted to the steering knuckles. The rear sensors are mounted at the outboard end of the axle. Tone wheels are mounted to the outboard ends of the front and rear axle shafts. The gear type tone wheel serves as the trigger mechanism for each sensor.



if you have no clue then put your stock wheels bac on and go to another dealer. Bring a vidoe of the issue.

BJB 11-07-2010 03:23 PM

Re: immediate help needed!!
 
Not sure if this helps or not, but I have a clear photo of what the tone ring looks like (With the brake caliper removed) It is located just behind the wheel flange (The ring with groves in it) The ABS or wheel speed sensor is pointed and looking at this ring. Once you are under there looking at it you wont have any trouble finding it. It is the only electrical connection located at the wheel assembly.


http://i423.photobucket.com/albums/p...Oct2007245.jpg

jasonjsl 11-07-2010 03:34 PM

Re: immediate help needed!!
 
i had the exact same problem with my 05 wk...it was the abs sensor wire..somehow got a nick in the wire and exposed theinner wiring.simple fix, bought new sensor wire and good to go. with the tire off youll notice a wire running from the top of the wheelwell to the sensor itself. the wire is fastend to the back of the wheelwell with wire clip. You cant miss it...give me a shake if you need any assistance.

Drew 11-07-2010 04:00 PM

Re: immediate help needed!!
 
any codes?

stealth32 11-07-2010 04:31 PM

Re: immediate help needed!!
 
no no codes the dealership said it was my tps throwing everything off which is bullshit because ive had the rims/tires on for over 5,000 miles with no problems. I drove it again today and no problems i saw the wire on the wheelwell and made sure everything was in place

stealth32 11-07-2010 06:50 PM

Re: immediate help needed!!
 
bumpp


All times are GMT -5. The time now is 06:14 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community