Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   "new" car noises (http://www.jeepgarage.org/f5/new-car-noises-14956.html)

4.whoa 11-09-2010 06:03 PM

"new" car noises
 
I recently got a '05 wk 5.7 limited(my 1st hemi) and am goin nuts with all the noises i'm not used to.:glare: I do most of my driving just in town and @ +/-40mph it jerks/surges. It's got clean oil, but i plan to change it tomorrow as i dont know what it really is (hoping its just as simple as 10w30 in it)

It seems the hatch is loose,not a rattle,but not snug. how do I tighten it up?

Also it seems to maybe have a slight miss, but i don't know if that's part of that mds crap or not. On the highway @ 75 or so its ok, but in town .... not so much.

It sounds like the steering pump is whinning,but not all the time, by chance is that from the hyd fan?

I'd appreciate any help, I just want to enjoy it, but I HATE little noises please help!

Chaoul1 11-09-2010 06:06 PM

Re: "new" car noises
 
Make sure your Put 5W20! Don't put 10W30!!!!!!!!!!!!!!!!!!!

Check your power steering fluid to see if it's low. If it's low just add some fluid into it.

4.whoa 11-09-2010 07:33 PM

Re: "new" car noises
 
I already got the 5w20 and will change tomorrow.Was thinking maybe someone else put in 10w30. The steering fliud is a little OVER full.

Chaoul1 11-09-2010 07:44 PM

Re: "new" car noises
 
Check your Serpentine Belt. See if has any cracks in the threads. If so, I would change it and that also might help out with the issue.

jes_96 11-10-2010 03:34 PM

Re: "new" car noises
 
For what it's worth, I managed to burn up a power steering pump in a Ford Ranger due to it being over-filled. Never really dug into the why's and wherefor's, but, from what my trusted local mechanic told me, some power steering pumps are more sensitive to over-filling, than under-filling.

4.whoa 11-10-2010 07:47 PM

Re: "new" car noises
 
Well, i changed the oil,put in 5w20 and i also changed the belt. It wasnt cracked, but it was soft,so i figured what the heck.
It runs a little better,but still not smooth and the old belt was making a squishing that is now gone,but i still hear the steering pump :banghead: it is about 1/2" above full,and there's plenty of room above it,but I'll still take some out tomorrow.

I'm getting new plugs tommorow, they only had 8,so hopefully that helps.

I've read a little about the infamous "hemi tick" but dont quite get the sound. Mine sounds like a flat tappet lifter thats making a little noise- :( which it obviously can't be, so is that it?

Can anyone tell me how to adjust the rear hatch?

Are there any manuels for these? The parts store says they dont have Chiltons/Haynes for these so what's left? just fsm's? what do they run?

4.whoa 11-13-2010 04:18 PM

Re: "new" car noises
 
Finally got the plugs changed today. the crossover wires snapped onto the plugs like normal, but the coils wouldn't. is that normal? It does run a little better,but STILL jerks at 40mph :angry:


All times are GMT -5. The time now is 04:53 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community