Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   overdrive not working right (http://www.jeepgarage.org/f196/overdrive-not-working-right-15151.html)

millertime 11-15-2010 01:24 PM

overdrive not working right
 
I have a 99 JGC limited 4.7l and the overdrive only kicks on at about115km/h and then downshifts at about 100km/h and it downshifts hard. fluid looks good and changed the throttle position sensor with no change. Also check engine light reads a p0700 which relates to the transmission but need to take it to dealer for more info. any suggestions what the problem may be. all other gearss seeem to shift fine. let me know what you think.

cheapjeep 11-15-2010 01:51 PM

Re: overdrive not working right
 
P0700 Transmission Control System Malfunction. I think that's one for the dealer to figure out. It could be a bad transmission control module next to the coolant reservoir.Maybe try one from a bone yard just make sure they'll let you return it if that doesn't work

paul_666 11-15-2010 06:28 PM

Re: overdrive not working right
 
Had a bit of an issue when I got mine - no overdrive at all!

P0700 on the dash just means that transmission ECU is throwing out a code.

I had an OBD2 scanner and it was telling me 'incorrect gear ratio in 1st'

Usually means one or both of the sensors on the gearbox are shot. Replaced mine (its a cheap part - $36 from memory (each)) and can be done without jacking the car up.

Gearbox was smooth as silk just replacing those two - about an hour for the pair. :)

Rather specific troubleshooting thread for the error I was getting here

Paul

numb3r1dad 11-16-2010 10:35 AM

Re: overdrive not working right
 
this is probably a stupid question but.. i always drive with o/d on. that's normal right?

cheapjeep 11-16-2010 12:42 PM

Re: overdrive not working right
 
Quote:

Originally Posted by numb3r1dad (Post 302110)
this is probably a stupid question but.. i always drive with o/d on. that's normal right?

I turn mine off when I tow depending on terrain but in everyday driving I leave it on

numb3r1dad 11-18-2010 08:56 PM

Re: overdrive not working right
 
Quote:

Originally Posted by cheapjeep (Post 302182)
I turn mine off when I tow depending on terrain but in everyday driving I leave it on

thanks

millertime 11-19-2010 08:48 PM

Re: overdrive not working right
 
jeep goes in monday i will let yous know what the problem is in case any one else has the same trouble thanks

millertime 11-25-2010 11:31 AM

Re: overdrive not working right
 
output speed sensor on the tranny works fine know

paul_666 11-25-2010 11:50 AM

Re: overdrive not working right
 
Quote:

Originally Posted by millertime (Post 307042)
output speed sensor on the tranny works fine know

Excellent!

Same issues as mine, think they are always a good place to start - I just replaced both of mine and now its really slick changing gears :)

Glad its all sorted :)

_clubman_ 12-04-2011 03:34 PM

Re: overdrive not working right
 
hello.. i have an 99 wj. in friday when i drive to the big city in sweden the gearbox begin to irritaded me. in overdrive its "tjong" an hacking... and now its beraly want to change gear under 2500 rpm... and only 3 speeding gears..

then the check engine begin to ligths.. and now i have borrowed an obdII reader.. the troble codes i see was p0733 gear 3 incorrect ratio. p0731 gear 1 incorrect ratio. p0734 gear 4 inco..... p0700 transmission control system malfunktion.

is this the famous out-input speeding sensors? ///fredde from sweden.

Frango100 12-04-2011 09:20 PM

Re: overdrive not working right
 
Welcome to the garage Clubman.
Before changing anything check the transmission fluid level and check the fluid for a burnt smell. If thats ok, it can be a good thing to change both the output and input speed sensors. If the transmission is not slipping, that could solve your problem.

_clubman_ 12-06-2011 06:40 AM

Re: overdrive not working right
 
change the both sensors yesterday.. now its normally again! :D erase the trouble codes whit the autoxray ez-scan 6000. but.. i tried to drive before the codes was erased.. the check engine lamp was on in a couple of swedish miles.. "20km" then the lamp disapperad... and after i took the autoxray and check.. the codes was in memory... and then i erase them whitout any troubles.


All times are GMT -5. The time now is 06:33 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community