Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK2 - (http://www.jeepgarage.org/f73/)
-   -   First jump start experience... (http://www.jeepgarage.org/f73/first-jump-start-experience-15191.html)

muzichio 11-16-2010 03:03 PM

First jump start experience...
 
I had to jump start another Jeep yesterday (a WK) and had mixed results. The other jeep would turn over a little but give up and not start with my end of the cables connected to the posts in the engine area. I have pretty thick cables and have not had an issue jump starting others before. So I tried going straight to the battery - a little cumbersome but easy enough- and that did the trick right away, first try.

Wonder if the engine bay posts (labeled with a little jumper cable diagram, as in place positive cable here and so on) are meant more for the "jumpee" rather than the "jumper"?

JoeSchmoe007 11-16-2010 03:18 PM

Re: First jump start experience...
 
How did you open battery cover under the seat? I tried but it wouldn't open and I didn't want to apply too much force.

Eurosport 11-16-2010 03:21 PM

Re: First jump start experience...
 
Quote:

Originally Posted by muzichio (Post 302242)
I had to jump start another Jeep yesterday (a WK) and had mixed results. The other jeep would turn over a little but give up and not start with my end of the cables connected to the posts in the engine area. I have pretty thick cables and have not had an issue jump starting others before. So I tried going straight to the battery - a little cumbersome but easy enough- and that did the trick right away, first try.

Wonder if the engine bay posts (labeled with a little jumper cable diagram, as in place positive cable here and so on) are meant more for the "jumpee" rather than the "jumper"?

nope, it'll work there too, the posts are for everything just like the battery would be there.
i know you guys are not used to battery location but since 1996 i've had always had it either in the trunk or under rear seat, always with terminals in the engine bay, all worked the same and meant to work the same, there's no "jumpee" as you put it..

moosehead 11-16-2010 03:21 PM

Re: First jump start experience...
 
Seems a bit odd as the wiring looks pretty robust up to the engine bay posts. It should be drawing at or near full battery power? Maybe the dead vehicle needed a bit more juice and the actual battery hookup was fourth or fifth cumulative try?

I was skeptical at first of the passenger seat battery compartment, but overall, it looks really well done.

jeep2011 11-16-2010 06:01 PM

Re: First jump start experience...
 
I jumped a WK the first week I had mine. No problems other than the connections are on opposite sides from one another.

muzichio 11-17-2010 01:40 PM

Re: First jump start experience...
 
Hmmm....sounds like his battery was just real dead, and the fifth time trying to jump start was the charm. Probably just coincidence that it worked when i went direct to the battery.

Joe, the battery cover let's go with a little bit of effort (and a "pop") but it seems to go back in ok.

Jim Hef 11-17-2010 02:38 PM

Re: First jump start experience...
 
If the battery is really dead, you need to let it charge a bit before you try to jump start it. Doesn't have anything to do with the posts or their location.

tank47 11-17-2010 08:28 PM

Re: First jump start experience...
 
Quote:

Originally Posted by moosehead (Post 302249)

I was skeptical at first of the passenger seat battery compartment, but overall, it looks really well done.

Moosehead did you get your jeep? If so id love to see a pic with those mopar wheels on.


All times are GMT -5. The time now is 07:51 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community