Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   Instrument Cluster Problems (http://www.jeepgarage.org/f5/instrument-cluster-problems-15736.html)

swing4terps 12-01-2010 09:28 AM

Instrument Cluster Problems
 
About 5 or so times in the past couple weeks, I will be driving and ALL of the lights on my instrument cluster will light up for a few seconds then turn back off. No real commonalities between occurences that I've seen. Anyone have any guesses? Ignition switch maybe?

mjl2610 12-01-2010 11:02 PM

Re: Instrument Cluster Problems
 
I had a similar issue where it would appear as if i took the key and turned the Jeep off then on repeatedly. The Jeep still drove fine and acted normal fir the exception of the cluster going crazy. After explaining to the forum what It might be looking for an answer before i took it to the dealer, it was suggested an ignition switch. Turned out the codes that were pulled pointed to a faulty ignition switch. It was replaced under warranty so i don't know the cost of something like that. Hope this helps.

Eaglelope 12-02-2010 09:17 AM

Re: Instrument Cluster Problems
 
I had the same issue on my 05 4.7L WK. There are a couple of large multi-pin connector blocks under the dash on the drivers side inside the cabin. I disconnected the battery then took those apart and cleaned them with a good electrical contact cleaning spray.
That fixed the issue for me.

harricanfloyd 12-03-2010 05:11 PM

Re: Instrument Cluster Problems
 
You have alot of Keys? have you recently powerwashed the motor. I had the same problem....I went down to 1-3keys and now power wash the motor (low pressure) with a bag over the ignition unit and the problem has gone away...

chicago_jeepster_ 12-03-2010 06:16 PM

Re: Instrument Cluster Problems
 
I had the same problem, but it would only do it when it was really cold out.

jcostri09 12-22-2010 04:35 PM

Re: Instrument Cluster Problems
 
has anyone changed out the ignition, not under warranty? Is it expensive, or difficult to do on your own?

swing4terps 12-23-2010 11:59 AM

Re: Instrument Cluster Problems
 
I think a new ignition switch is around $50 or so. Probably something you can do yourself. This may help.

http://www.jeepgarage.org/showthread...gnition+switch

GratefulDeadWK 12-24-2010 08:53 AM

Re: Instrument Cluster Problems
 
Quote:

Originally Posted by swing4terps (Post 322410)
I think a new ignition switch is around $50 or so. Probably something you can do yourself. This may help.

http://www.jeepgarage.org/showthread...gnition+switch

I actually saw one for thirty, but do you have to re learn the key or anything when you put a new switch in?

I as well have the same problem and it happens at the weirdest times, sometimes not for months and then it will come back to haunt me. My switch seems loose where you stick the key in, has a lot of play so I'm thinking that is prob the case. I do want to try what a guy said a few posts up by cleaning out the wires under the dash, might help as well.

Also one more thing and this is just a theory. I have a broken off ground strap under my car, its the one that goes from the exhaust to the body. I've never got around to fixing it but could be part of the problem.

gudman 12-24-2010 02:27 PM

Re: Instrument Cluster Problems
 
Hello all friends!
Sorry for my English, a translator Google.
We are witnessing in Russia is often the same problem!
This problem occurs most often in damp cold weather.
Found the solution! Need to change the contact group, the ignition switch.
Problem was solved TriA service in Moscow. I thank them for it ...
I would be glad if it is useful to you!
Discussion topic: http://jeepgarage.ru/forum/topic.php?forum=63&topic=16


All times are GMT -5. The time now is 02:04 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community