Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f80/)
-   -   Led tail lights problem (http://www.jeepgarage.org/f80/led-tail-lights-problem-15744.html)

THEIFNDNIGHT 12-01-2010 10:53 AM

Led tail lights problem
 
I own a 2008 jeep srt-8 i purchased a set of led tails from racer union i also have the lipz rear fogs harness and conversion.
Now i lost the top portion of the tail light first on one side then on the other.
Has anyone experience the same problem

robpp 12-01-2010 11:02 AM

Re: Led tail lights problem
 
i would look at the connections, #1. then check the fuses. wkjeeps has all the locations.

maybe try to plug in the original light and see if it all works. that might help identify is it a jep issue or the lamps themselves.

we have heard of peeps losing one LED here and there but not the whole side,

wkjeepgirl86 12-04-2010 09:43 PM

Re: Led tail lights problem
 
Quote:

Originally Posted by THEIFNDNIGHT (Post 310035)
I own a 2008 jeep srt-8 i purchased a set of led tails from racer union i also have the lipz rear fogs harness and conversion.
Now i lost the top portion of the tail light first on one side then on the other.
Has anyone experience the same problem

I tried putting in led bulbs in my tail lights the other day and for some reason it blew the fuse. the turn and parking lights are on separate fuses for each side. I had to go to work so i quickly threw a fuse in and haven't tried putting the bulbs back in. the only thing i can think of is i had the lights on when i was putting the bulbs in and out and it shorted something. not sure what to do going to try it again tomorrow with the lights off this time

robpp 12-04-2010 10:02 PM

Re: Led tail lights problem
 
Quote:

Originally Posted by wkjeepgirl86 (Post 312076)
I tried putting in led bulbs in my tail lights the other day and for some reason it blew the fuse. the turn and parking lights are on separate fuses for each side. I had to go to work so i quickly threw a fuse in and haven't tried putting the bulbs back in. the only thing i can think of is i had the lights on when i was putting the bulbs in and out and it shorted something. not sure what to do going to try it again tomorrow with the lights off this time

the OP is talking about LED taillight assembly. NOT LED taillight bulb.



dont bother trying it again. you need what they call a CK bulb for the rear as well as a 6 ohm resistor. the resistor gets wired across the outer wires of the main 3 wire plyg. resistor gets hot so it need a safe place to mount.

both v-led and autolumination sell ck bulbs.

kocor321 12-31-2010 03:12 PM

Re: Led tail lights problem
 
Quote:

Originally Posted by THEIFNDNIGHT (Post 310035)
I own a 2008 jeep srt-8 i purchased a set of led tails from racer union i also have the lipz rear fogs harness and conversion.
Now i lost the top portion of the tail light first on one side then on the other.
Has anyone experience the same problem


Common problem, I went through one set and bought another. Happened to a few of my friends also.

I heard it happens often, if my second set breaks I am not replacing it. I did hear though that some people were successful with getting replacements from the manufacturer.


All times are GMT -5. The time now is 01:28 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community