Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK2 - (http://www.jeepgarage.org/f73/)
-   -   New Overland today, couple issues (http://www.jeepgarage.org/f73/new-overland-today-couple-issues-15861.html)

jpro 12-03-2010 05:54 PM

New Overland today, couple issues
 
I picked up my vehicle today, very very impressed with look, ride quality, and features. But I have a few questions and notes on things not working for you all:

Overland Hemi
Silver
Saddle/Black
ORII
Rear Ent
RHB 430N

1. It has about 75 miles on it now, and when sitting at idle it really keeps throwing a lot of white smoke out the exhaust. Pretty clearly oil to me. Should this have stopped already?

2. The EVIC. Tire Pressure says "OK". But when I check it, 3 tires are at 43 psi, the right rear is at 33 psi. That doesn't seem OK to me. What should the pressure be? And is the EVIC broken to not alert me to the difference?

3. Blue Tooth pairing of my iPhone 4 took almost an hour, it just wouldn't do it, but I kept turning the car and phone off and on and trying again, and finally it took. Interesting. No further problem. But interesting.

4. The console USB port doesn't seem to work. It doesn't charge nor data connect with my iPhone 4. Any ideas? or is it just broken?

5. Some of the plastic caps on the floor in back that cover seat bolts and such are busted off. Seems petty to complain, but would it be easy for the dealer to replace?

Thanks.

jeep2011 12-03-2010 06:02 PM

Re: New Overland today, couple issues
 
Congrats on the new GC!

White smoke is not a sign of burning oil, that would be blue/grey smoke.

What is the temp there, it sounds like perfectly normal condensation smoke due to the air temp and humidity.

Otherwise thick white smoke is a sign of burning water/coolant in the cylinders. Highly doubtful on a new car.

GlowingGhoul 12-03-2010 06:02 PM

Re: New Overland today, couple issues
 
Quote:

Originally Posted by jpro (Post 311506)
I picked up my vehicle today, very very impressed with look, ride quality, and features. But I have a few questions and notes on things not working for you all:

Overland Hemi
Silver
Saddle/Black
ORII
Rear Ent
RHB 430N

1. It has about 75 miles on it now, and when sitting at idle it really keeps throwing a lot of white smoke out the exhaust. Pretty clearly oil to me. Should this have stopped already?

2. The EVIC. Tire Pressure says "OK". But when I check it, 3 tires are at 43 psi, the right rear is at 33 psi. That doesn't seem OK to me. What should the pressure be? And is the EVIC broken to not alert me to the difference?

3. Blue Tooth pairing of my iPhone 4 took almost an hour, it just wouldn't do it, but I kept turning the car and phone off and on and trying again, and finally it took. Interesting. No further problem. But interesting.

4. The console USB port doesn't seem to work. It doesn't charge nor data connect with my iPhone 4. Any ideas? or is it just broken?

5. Some of the plastic caps on the floor in back that cover seat bolts and such are busted off. Seems petty to complain, but would it be easy for the dealer to replace?

Thanks.

1: The small amount of white smoke is normal for the HEMI. A miniscule amount of oil is recirculated into the intake with the exhaust gases being reburned. This will lessen with engine break in. There is a "catch can", which is a simple, 5 minute install device that intercepts oil and moisture (it's actually this moisture responsible for 99% of the "smoke") and stops the smoke completely, and you empty it every oil change. I wouldn't worry about it, the HEMI is bulletproof.

2: The tires aren't UNSAFE, so the evic won't alert. Correct pressure is 36 PSI all the way around. I had 43 PSI on mine, too, and it makes the ride MUCH harsher than it should be. Lower those to 36 PSI and the ride will noticeably improve.

5: Yes, make the dealer fix it. It's cheap and easy, and it's part of what you should expect for $40k+. You may want to call the service department and register this with them, so you can wait until you need to go in for something else and they won't blame the broken caps on you.

NYCSRTATE 12-03-2010 06:07 PM

Re: New Overland today, couple issues
 
Sounds like the dealer did a half ass job of prepping the vehicle.


Im shocked, take it back and have them fix everything.

jonesark 12-03-2010 06:33 PM

Re: New Overland today, couple issues
 
Pics of that saddle would be nice!!

mabeaton 12-03-2010 06:36 PM

iPhone 4 issues are common on the 730n. Supposed to be a fix coming in an update. USB on the radio-does not supply power. It is used for transferring pics and music from memory sticks.

jpro 12-03-2010 07:08 PM

Re: New Overland today, couple issues
 
Well, I have the 430N, and like I said the Bluetooth works pretty well with the iPhone 4. AND the USB on the radio on my model DOES supply power to the iPhone. But the console usb should supply power and data comms, and it does neither.

Quote:

Originally Posted by mabeaton (Post 311535)
iPhone 4 issues are common on the 730n. Supposed to be a fix coming in an update. USB on the radio-does not supply power. It is used for transferring pics and music from memory sticks.


jpro 12-03-2010 07:11 PM

Re: New Overland today, couple issues
 
It would be a hassle to put out photos that really do it justice. But in my honest opinion it looks pretty orange. An orange brown. To each their own on what "Saddle" looks like. But it looks good. Nothing but stunning to everybody who's seen it so far. I think the silver looks particularly upscale with it too.

Quote:

Originally Posted by jonesark (Post 311531)
Pics of that saddle would be nice!!


JoeSchmoe007 12-03-2010 07:51 PM

Re: New Overland today, couple issues
 
Quote:

Originally Posted by GlowingGhoul (Post 311512)
1: The small amount of white smoke is normal for the HEMI. A miniscule amount of oil is recirculated into the intake with the exhaust gases being reburned. This will lessen with engine break in. There is a "catch can", which is a simple, 5 minute install device that intercepts oil and moisture (it's actually this moisture responsible for 99% of the "smoke") and stops the smoke completely, and you empty it every oil change. I wouldn't worry about it, the HEMI is bulletproof.

2: The tires aren't UNSAFE, so the evic won't alert. Correct pressure is 36 PSI all the way around. I had 43 PSI on mine, too, and it makes the ride MUCH harsher than it should be. Lower those to 36 PSI and the ride will noticeably improve.

5: Yes, make the dealer fix it. It's cheap and easy, and it's part of what you should expect for $40k+. You may want to call the service department and register this with them, so you can wait until you need to go in for something else and they won't blame the broken caps on you.

I think 36 is correct pressure for 20" wheels. OP has OR II so probably has 18" wheels. For them correct pressure on my Laredo X is 33. But check the label on your car to be sure.

GlowingGhoul 12-03-2010 08:11 PM

Re: New Overland today, couple issues
 
Quote:

Originally Posted by JoeSchmoe007 (Post 311557)
I think 36 is correct pressure for 20" wheels. OP has OR II so probably has 18" wheels. For them correct pressure on my Laredo X is 33. But check the label on your car to be sure.

Oh man, I hadn't caught that. Thanks for correcting me.

funkatation 12-03-2010 08:42 PM

Re: New Overland today, couple issues
 
I couldn't get the iPhone 4 to work in the console USB either. A 2nd gen nano, 1st gen iPod video, and iPod touch 2nd gen worked perfectly though. Bluetooth streaming doesn't work at all, it stutters like crazy. The only iPod I tried that didn't work was a iPod color from 2004.

Mark Paul 12-03-2010 08:54 PM

Re: New Overland today, couple issues
 
(1) Congratulations on your new Overland!

(2) What iOS version of the iPhone do you have installed? The latest 4.2.1?

(3) Please take photos of your interior and post!!!!

ENJOY!!!!


All times are GMT -5. The time now is 08:08 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community