Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - ZJ (http://www.jeepgarage.org/f78/)
-   -   Jeep 5.9 Cooling Fan Switch (http://www.jeepgarage.org/f78/jeep-5-9-cooling-fan-switch-16119.html)

crf250r83 12-10-2010 12:54 PM

Jeep 5.9 Cooling Fan Switch
 
I'm Having Problems finding A Solution To Replacing A Upper Radiator Hose Fan Switch! Any Ideas Or Working Solutions Anyone Has Come Up With?

1 GRAND 12-11-2010 06:09 PM

Re: Jeep 5.9 Cooling Fan Switch
 
Never had any issues with mine, so I can't help. But good luck.

jimmy vegas 12-21-2010 02:18 AM

Re: Jeep 5.9 Cooling Fan Switch
 
Quote:

Originally Posted by crf250r83 (Post 315298)
I'm Having Problems finding A Solution To Replacing A Upper Radiator Hose Fan Switch! Any Ideas Or Working Solutions Anyone Has Come Up With?

hey man i am new to this sight so probaly not the man to talk to ,, i had the same prob but no one could figure out exactly whitch or what part was the culprit so i cut out the old fan motor and kept shroud ,,,bought a 70$ 16 in electric at advance and got a 25$ harness that pokes in your rad to tell fan when to come on ,,,i have mine turned down to 170 but it doesnt kick on till 210 but you have to be going slow and up hill for it to hit 210 ,,soon as it comes on it drops about 20deg ,,,looks stock to ,,,probaly not the answer u were lookin for but i just had that prob last week so had to mention ,,hope you get it licked man, run about 190 98% of the time ,,has not got hot since and i sat in pals drivthru foreverrrrrrrrrrrrrrrrrrrrrrrrrrrr today prob idoled for 25 min ,got to 210 about 10 15 min in and fan kicked on stayed around 190 195

jeepnjeep 12-21-2010 09:40 AM

Re: Jeep 5.9 Cooling Fan Switch
 
My son has a 5.9 and is on here some times. He found a solution to this prob but I don't remember it. I'll have him post it up when he gets home tonight.

Jeep95XJ 12-22-2010 07:33 PM

Re: Jeep 5.9 Cooling Fan Switch
 
I thought i found a solution but i didnt. There is no switch made to replace the stock one. Jeep stoped making them years ago and they were never made by any aftermarket company. Are you 100% sure it's the switch and not the low speed on the motor or the low speed relay?

To test for the exact problem you have to do a few things

Turn the key to ignition but dont start your jeep. Unplug the upper switch and jump the 2 terminals out with a peper clip, piece of wire, whatever you have. If your fan kicks on then chances are its a bad switch. If the fan doesnt kick on BUT you hear a click next to the battery then its the fan motor. If you dont get a click next to the battery then the low speed relay is bad. Diagnose the problem and see what you come up with. You can move the lower hose switch to the upper hose if need be. You cant swap the t fittings they are different sizes. You have to move the switch itself.

I did find a sensor from BECOOL. I bought it but have never tested it. The part # is 75099 (check JEGS $40) and its very close to the stock specs on our switches. Only thing is its a 1 wire switch so you will have to figure out a way to ground the actual t fitting. One of the 2 wires going to the stock switch would go to the body of the switch or the t fitting and the other would go to the terminal on top of the BECOOL switch. What i plan to do when i put it to the test is weld a small nut to the t fitting and use a screw with a ring terminal so attatch the ground wire to the housing of the t fitting. Should work just fine.

apstang50 12-27-2010 02:53 PM

Re: Jeep 5.9 Cooling Fan Switch
 
The low speed on the fan was burnt out on my 5.9 when I bought it. I just wired a switch into the wiring for the low speed sensor so I could turn it on when I needed. You should be fine switching the sensors, the engine never gets hot enough for the high speed to come on. And you could wire a switch for the high speed so you could turn it on if you need to. Last time I check to dealer only sells the hose, t fitting, and sensor for some ungodly amount.


All times are GMT -5. The time now is 03:22 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community