Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Installed my LED Reverse bulbs and.... (http://www.jeepgarage.org/f107/installed-my-led-reverse-bulbs-and-19501.html)

RyeGuy 02-27-2011 01:41 AM

Installed my LED Reverse bulbs and....
 
Passenger side works perfectly but the drivers side is completely out. I used the Putco 360 7440 & 921 bulbs for the install, which i have seen other members use and not need resistor. Does anyone have any idea as to what is going on?

White Chocolate 02-27-2011 03:46 AM

Re: Installed my LED Reverse bulbs and....
 
Probably a dead bulb....thats what happened to me. Shit happens. Did you try putting bulb in other side to see if its burnt out?

moosehead 02-27-2011 10:02 PM

Re: Installed my LED Reverse bulbs and....
 
RG, maybe try rotating the bulb that is out 180 degrees?

The DRL LED's have polarity alignment and will only fire if plugged on correct side.

lll2for3lll 04-27-2011 07:30 PM

Re: Installed my LED Reverse bulbs and....
 
I know that the 05-07 model requires 3157 bulb for the reverse lights.

My question is what type of 3157 LED bulbs do I need from VLEDS? I know that Toyotas require a special made 3157 LED bulb...one of the switchbacks I think.

Will my 05 WK need the switchbacks in the reverse?

robpp 04-27-2011 07:36 PM

Re: Installed my LED Reverse bulbs and....
 
ALL reverse bulbs just use a straight repalcement; 3157 for 3157 or 921 for 921.

The bulbs you talk about, the toyota bulbs, also known as CK bulbs are needed for the 07+ tailight bulb.

oh and NO resistor needed for any reverse lights.

lll2for3lll 04-27-2011 07:43 PM

Re: Installed my LED Reverse bulbs and....
 
Thanks a lot rob. I knew that no resistor was needed. I just didn't know if I need the CK type for my reverse. Thanks.

While I'm at it, would I need the CK type for my turns or is that for 07+?

robpp 04-27-2011 07:46 PM

Re: Installed my LED Reverse bulbs and....
 
i cant swear on the early ones but i think you do NOT need them.

but I am not sure as I have an 07 :D

I am retrofitting an early set so i have 3 bulbs on my 07. I bought NON CK so they better work.
but I wont know 100% form a few weeks.



if you have a circiut tester you could find out quick. over in the vendor section under LIPSCHITZWRATH i posted a good pic that shows CK and NORMAL sockets and how to tell what you have.
or go to autolumination.com they have pics there.

lll2for3lll 04-27-2011 07:52 PM

Re: Installed my LED Reverse bulbs and....
 
I'm a little concern now because I was going to use AL switchbacks but the don't verify what type they have. I don't even think they have any in stock.

lll2for3lll 04-27-2011 08:10 PM

Re: Installed my LED Reverse bulbs and....
 
Ok rob, I just found out that Frankie has Standard Switchbacks in his 06.

robpp 04-27-2011 09:21 PM

Re: Installed my LED Reverse bulbs and....
 
the front dont need CK - ANY YEAR. its only the rear 07+


All times are GMT -5. The time now is 04:31 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community