Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   05 Limited with some issues..Need Help (http://www.jeepgarage.org/f5/05-limited-with-some-issues-need-help-19504.html)

HemiPower 02-27-2011 07:43 AM

05 Limited with some issues..Need Help
 
I have owned the jeep for about 3 years, I have couple of problems:

The first is the Instrument cluster is going from dim to bright occasionally, as far as I can tell this is the only lights effected the headlights remain constant so do my evac lights.

Two is at start up I get a rough idle, it threw a code P0300 random misfire. It runs fine, drives fine idles fine after startup. I had this same problem over a year ago, Last year I Replaced plugs with OEM copper plugs, ran a fuel system cleaner, it did it again a week later took it to the dealer they couldn't get it to do it. They had two days, cleared the code and it never came back till last night. Any Ideas?

And I bent a Rim last night, ruff night for the jeep

In the last 6 months, New Starter, New Battery

Scottina06 02-27-2011 01:45 PM

Re: 05 Limited with some issues..Need Help
 
the p0300 is a random misfire..so it could be any of these things, bad plug, wire, coil, cat converter(smell rotten eggs or bad smell from the exhaust?) but with the 5.7's its seems to be the egr valve most often or a vacuum leak in the intake mani.

05wkguy 02-28-2011 01:06 PM

Re: 05 Limited with some issues..Need Help
 
I had the guage light flicker issue you describe. I found that when i adjust the brightness down a notch or two it went away. I asume this means the problem lies in the turn signal stalk but i would run the brightness at that level anyway so i don't worry about it.


All times are GMT -5. The time now is 05:41 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community