Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   first issue with my WK2 - quadra lift (http://www.jeepgarage.org/f107/first-issue-with-my-wk2-quadra-lift-19959.html)

chibianh 03-08-2011 06:48 PM

first issue with my WK2 - quadra lift
 
I finally am experiencing my first "major" issue with the WK2 this past week. But to clarify, it's not a show stopper or anything, hence I put the word major in quotes. Just as a background, I've owned the Jeep since Sept, am in the mtns a lot, use quadra lift all the time and have had no issues until this. Anyway, the issue is when I go to raise the vehicle, I'd get the 'suspension needs cooling' message. Eventually however, after a few minutes, it'd raise to the desired setting. It'd have no problems lowering, though. I tried over the next several days and each time would get the message, but again, it would raise to the desired setting after a few minutes. There were posts here from others saying all that was needed was to clear the error code from the computer and it'd be back to normal. So, I took it in to get it serviced and the service manager said he'd try that. After taking a look at it, I found out I needed one of the shocks replaced because it was leaking and clearing the code had not resolved the issue. So, they got jeep engineers on the line and after some troubleshooting, they are sending out a new compressor.

In the meantime, quadra lift still works.. just slowly. The part won't be here for about 5 days, but I am leaving on my road trip in 3. So, the replacement of compressor will have to wait until I get back. They say I should be fine for on road driving, as well as off-road driving.. I just gotta be a little bit more patient when lifting the vehicle. I guess I'll find out! (road trip is to Moab and Grand Canyon and no doubt I will be finding some trails to run!)

moosehead 03-08-2011 07:18 PM

Re: first issue with my WK2 - quadra lift
 
Where do you go for Jeep service here C? Was the shock replaced and you're just waiting on the compressor? Safe travels to Moab, hope she stays good, you got ballz.

RyeGuy 03-08-2011 07:36 PM

Re: first issue with my WK2 - quadra lift
 
Sorry to hear this, but it will get fixed and you be back to normal like it never happened. However, if you go to Moab and the Grand Canyon and don't come back with pictures your gonna have some bigger probelms then your QL. LOL Im just kidding have fun.

chibianh 03-08-2011 09:02 PM

Re: first issue with my WK2 - quadra lift
 
Quote:

Originally Posted by moosehead (Post 371847)
Where do you go for Jeep service here C? Was the shock replaced and you're just waiting on the compressor? Safe travels to Moab, hope she stays good, you got ballz.

yep.. got the shock replaced. just need to replace the compressor now.

Quote:

Originally Posted by RyeGuy (Post 371865)
Sorry to hear this, but it will get fixed and you be back to normal like it never happened. However, if you go to Moab and the Grand Canyon and don't come back with pictures your gonna have some bigger probelms then your QL. LOL Im just kidding have fun.

definitely will have some pics

Cperez 03-08-2011 10:23 PM

Re: first issue with my WK2 - quadra lift
 
Props for your level-headed approach to this issue, chibianh. Looking forward to seeing what you post up to your blog! Have fun and be safe.

chibianh 03-28-2011 08:42 AM

Re: first issue with my WK2 - quadra lift
 
Just a quick update on this issue-- I recently came back from a long road trip and something must've happened along the way, but my Quadra-Lift is functioning normally again! I called up my service manager and he still recommended I take the Jeep to replace the part that was originally diagnosed by his techs and jeep engineers to be the problem. I'm thinking I should.. just so it won't happen again.. but, another part of me is thinking that if it's working, why replace it? What do you think?

STIX 03-30-2011 06:22 PM

Re: first issue with my WK2 - quadra lift
 
Me and boarderman have the same issue. For me they cleared the code and reset the QL module and I was fine but now it's back to the dealer tomorrow.

The overheat fault code had them scratching their heads since the computer captured the temp readings at each of the bags and tank an they were well within the operating limits...the compressor has a limit of something like 260 degrees and I was in the 60 degree range (it was cold out when all this happened).

I may have to have the module replaced. Seems like the common thread for each of us is that wevall have earlier builds. In any event it will be good to see what they recommend for you. When you pick up your jeep ask them for the svc record coorespondence. They should give it to you no problem and it will help us all out.

Good luck.

chibianh 03-30-2011 08:58 PM

Re: first issue with my WK2 - quadra lift
 
Quote:

Originally Posted by STIX (Post 386136)
Me and boarderman have the same issue. For me they cleared the code and reset the QL module and I was fine but now it's back to the dealer tomorrow.

The overheat fault code had them scratching their heads since the computer captured the temp readings at each of the bags and tank an they were well within the operating limits...the compressor has a limit of something like 260 degrees and I was in the 60 degree range (it was cold out when all this happened).

I may have to have the module replaced. Seems like the common thread for each of us is that wevall have earlier builds. In any event it will be good to see what they recommend for you. When you pick up your jeep ask them for the svc record coorespondence. They should give it to you no problem and it will help us all out.

Good luck.

I didn't see your post until now and I had picked up my Jeep earlier this morning. Here's what they have on the copy of my invoice:

9463 COMPRESSOR DEFECTIVE 08441201 1.4 FC58 1.4 RAN STAR SCAN TEST FOUND FAULT FOR COMPRESSOR OVERTEMP REPLACED COMPRESSOR PER SVC MANUAL TESTED OPERATING OF SUSPENSION ALL OK

So it looks like they just replaced the compressor unit. I'll see if my service manager can email me a copy of the service correspondence.

the1jake 03-31-2011 04:02 PM

Re: first issue with my WK2 - quadra lift
 
You have a good service manager there. Give some props to him and the dealership for taking care of this right away and not taking a chance for something to happen in the future, even if it was functioning properly after the initial problem.

STIX 04-04-2011 05:10 PM

Re: first issue with my WK2 - quadra lift
 
Engineers recommended the entire module be replaced. I'll have it back tomorrow.


All times are GMT -5. The time now is 04:45 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community