Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio/Visual/Navigation (http://www.jeepgarage.org/f155/)
-   -   Bluetooth question (http://www.jeepgarage.org/f155/bluetooth-question-20108.html)

jlag305 03-11-2011 12:59 PM

Bluetooth question
 
So every time I play music from my iphone 4 through the BT connect it sounds like crap. I brought it up to the dealer and they said they thought one of my speakers was blown. I brought it in and they installed a new door speaker and it sounds great when I play the radio, CD, Satellite and HDD but still am having issues when I use Bluetooth. Now I understand that MP3's are sometimes lower quality than CD but I am getting almost a rattling paper sound on all of the high end parts of all songs.

I dont know what it could be and am wondering if its a 430 problem, maybe software issue or what.

Anyone else getting anything similar?

jwojcins 03-11-2011 01:04 PM

Re: Bluetooth question
 
Works the same on my 430n when I listen to Pandora through my Bberry. I dont think it is anything other than Bluetooth not being that great at streaming music.

jlag305 03-11-2011 01:20 PM

Re: Bluetooth question
 
So once there is the update and the USB will read the Iphone 4, then will the quality improve?

Dunecrawler 03-11-2011 01:24 PM

Re: Bluetooth question
 
Not sure if this is related, but I noticed that my Bluetooth keeps dropping out when I put the phone in one of the cup holders. It is a 730 though. This is for calls also. It works fine when I keep it anywhere but the cup holder.

jwojcins 03-11-2011 01:33 PM

Re: Bluetooth question
 
hmm, thats pretty weird Dunecrawler. I have not noticed a difference in reception for calls or streaming music whether the phone is in the cupholder, my pocket, lap, armrest etc.

jlag305 if you are connecting through the USB, you will not be using Bluetooth. Therefore, you should notice that the sound quality is vastly improved. I dont think there is anything available to make music streaming via Bluetooth sound any better

jlag305 03-11-2011 03:21 PM

Re: Bluetooth question
 
My wife has a lexus is250 and I use the Bluetooth in her car and there is no sound difference or similar sound degradation as in my JGC.

I guess I will just have to live with it until I can use the USB

jwojcins 03-11-2011 03:40 PM

Re: Bluetooth question
 
maybe it is specific to UConnect then....I have no experience with streaming music on Bluetooth in other vehicles. Let us know if your dealer ever manages to fix it jlag305.:)

Cperez 03-11-2011 04:12 PM

Re: Bluetooth question
 
Quote:

Originally Posted by jlag305 (Post 373829)
So once there is the update and the USB will read the Iphone 4, then will the quality improve?

Don't hold your breath waiting for a reliable answer to that. The update is still vaporware-- it's not available-- so no one can possibly answer that question at this point in time.

However if it's speculation you desire you came to the right place. :D

Radside 03-11-2011 04:22 PM

Re: Bluetooth question
 
I don't have that problem when I stream BT...when it isn't playing in fast forward, it sounds finds. The problem that you are describing sounds as thought your volume is turned up to high on your phone or (but not likely) the music was recorded so hot that it has digital clipping.

wreckdive 03-11-2011 04:57 PM

Re: Bluetooth question
 
There is much to be said on this topic, and I ain't the one to say it (all). Here's a not-quite-up-to-date link explaining some of the issues:
http://www.wirelessaudioblog.com/wab...-a2dp-ste.html
A software update may help, but some of the issues are embedded in your smartphone/player of choice. Higher-quality audio codecs exist but are not universal in implementation yet, so expect variations between different vendors.

jlag305 03-12-2011 07:39 PM

Re: Bluetooth question
 
I am very familiar with clipping as I am a big music guy, going to school for it and working in the industry. Unfortunately this sounds like a bigger problem almost like a distortion on the high end spectrum. If you can think of the sound of blown speakers (paper rattling) but only on the tweets? I know it sounds weird but that's the best way I can describe. Again - system sounds great for radio, satellite, cd and hard drive. I gotta assume it has a problem with the hardware or software with the 430.

wreckdive 03-12-2011 08:27 PM

Re: Bluetooth question
 
Troubleshooting this stuff can drive ye to drink! Assuming your source data sounds A-OK with a hardwired connection, then you're left with either a flawed BT implementation/codec on your playback source device, or flawed BT implementation on the 430, or even a bad (soldered?) connection between the 430 and speakers? Since you now have new speakers, maybe we can rule them out of the equation. I feel your pain. . . I hate it when this stuff throws up.

I'd try this if possible: (start with a refreshing beverage of your choice - mine might be alcoholic) If you have a laptop that is Bluetooth capable, see if you can pair that into the 430 (I have no idea if this is even possible with the 430, but BT is BT at base level so it should work). Play the same source data (music) file from the laptop and note if it sounds any better or same junk you've been getting. If audio is better, then you know the problem is most likely in your iPhone 4G.

A known problem involves trying to use Bluetooth while WiFi is activated on the iPhone. They both share the 2.4HGz frequency. Way to go, Apple! FWIW, iPhones have been notoriously flaky with all manner of Bluetooth headsets, evidently a less than state-of-the-art implementation of A2DP protocol.

With regard to other Bluetooth devices (headphones, etc. , not necessarily a 430 or 730r), some have reported getting better results if re-pairing to the receiving device, making a new passcode.

Some have reported low-bit-rate audio rips have compromised audio similar to what you have described, whereas higher bit-rates have sounded significantly better.

At about this time, I am ready for a second beverage of choice, and would summarily blame. . . ??? Apple? Chrysler? Canada? Like I said, I hate troubleshooting this stuff. I'm picking up a guitar, plugging into a plexi Marshall, and crankin' her up to "eleven". No Bluetooth, no worries! :D

Good luck, and keep us posted. If I had my Summit (by the looks of things, next Winter, a year after ordering) I'd probably be suffering alongside ya, and might have better advice!


All times are GMT -5. The time now is 01:22 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community