Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Engine Performance/Intake/Exhaust (http://www.jeepgarage.org/f196/)
-   -   Not Running Right... (http://www.jeepgarage.org/f196/not-running-right-20113.html)

ylimits 03-11-2011 04:45 PM

Not Running Right...
 
Ok this is kinda of hard to explian but I will do me best I have a 2004 limited and sometimes it runs fine but other times when im driving and i nail the gas to pass someone all it seems to do is bog or just really not pick up speed at all but other time i can nail it and it will set u back in the seat i hope yall can help me out on this one. Also there are no codes and the check engine light does not come on.

Scottina06 03-11-2011 07:18 PM

Re: Not Running Right...
 
4.7 v8 ho.....hmmmm...let me do some thinkin'

ylimits 03-11-2011 11:33 PM

Re: Not Running Right...
 
im sorry i forgot to put that it is not an ho

Scottina06 03-11-2011 11:47 PM

Re: Not Running Right...
 
no traction control light or can you feel traction control kick in?

DJ BoNiOmArIo 03-12-2011 12:07 AM

Re: Not Running Right...
 
Does your engine die?

If not check your transmission fluid level and see if there's a leak from the pan. Usually if it's low in fluid the torque converter is not catching right and it's slipping therefore causing it to bog at times and when it does catch it goes.

That's the cheapest and easiest check if that doesn't work we can try guiding you through the next steps

ylimits 03-12-2011 09:15 AM

Re: Not Running Right...
 
Checked the tranny fluid and its fine it was. and no traction control light and i dont feel it kick in at all.

Frango100 03-12-2011 12:26 PM

Re: Not Running Right...
 
Do we have a traction control light on our WJs? Or do you have a 2004 WK?
I had a similar problem some time ago, it was only always there and not once in a while. Driving around town all ok, but when accelerating on the highway there was just lack of power. Passing some other car was just a risky thing. After changing my fuel filter/pressure regulator the problem was solved. Problem could also be with the fuel pump or even with the TPS sensor. If you have the possibility to measure the pressure at the fuel rail, you will know more.

bigboy189 03-12-2011 06:49 PM

Re: Not Running Right...
 
"Driving around town all ok, but when accelerating on the highway there was just lack of power." the tps sensor did it for me


All times are GMT -5. The time now is 08:02 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community