Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Audio/Visual/Navigation (http://www.jeepgarage.org/f155/)
-   -   430N (RHB) gives me the blank, then white SCREEN OF DEATH!...nothing works! (http://www.jeepgarage.org/f155/430n-rhb-gives-me-the-blank-then-white-screen-of-death-nothing-works-20302.html)

THEPRFCT10 03-15-2011 08:32 PM

430N (RHB) gives me the blank, then white SCREEN OF DEATH!...nothing works!
 
I searched this forum but other than someone's 730 Nav screen, I cannot figure this one out:

First few turn ons and offs today doing errands and it (nav radio screen)worked like a charm as usual. Then, third time today, I get a blank screen and none of the buttons work, both on screen and every hard button--nothing, nada, zilch!

Took it to the dealership today and they were very quick to order another radio, but man what a pain in the a$$ because I had all my music, bluetooth, etc., all setup already! I've only had the Jeep for 3 months, 1700 miles! Unreal! I hope this isn't a trend.....I know, electronics!

Any ideas? Can we reboot via some fancy combination of key presses? Had to ask. Thanks again for any suggestions!

~10

kmt16 03-16-2011 08:46 AM

My 730 froze once and I popped out the Green 30 fuse I think its the only one and put it back in. Worked fine ever since.

THEPRFCT10 03-16-2011 09:07 AM

Re: 430N (RHB) gives me the blank, then white SCREEN OF DEATH!...nothing works!
 
They want to replace the radio, but I'm willing to check the fuse although I'd like to think they checked that. Any idea if the 430N RHB fuse is the same or how to verify which one to pull and reset? Thanks!

Radside 03-16-2011 06:56 PM

Re: 430N (RHB) gives me the blank, then white SCREEN OF DEATH!...nothing works!
 
Quote:

Originally Posted by THEPRFCT10 (Post 376801)
They want to replace the radio, but I'm willing to check the fuse although I'd like to think they checked that. Any idea if the 430N RHB fuse is the same or how to verify which one to pull and reset? Thanks!

It's the M12 fuse. Leave it out for about 5 mins to reset the radio.

THEPRFCT10 03-16-2011 07:16 PM

Re: 430N (RHB) gives me the blank, then white SCREEN OF DEATH!...nothing works!
 
Quote:

Originally Posted by Radside (Post 377143)
It's the M12 fuse. Leave it out for about 5 mins to reset the radio.

Thanks for that, quick questions: Car on or off, or just pull and reset?

Radside 03-16-2011 07:47 PM

Re: 430N (RHB) gives me the blank, then white SCREEN OF DEATH!...nothing works!
 
Quote:

Originally Posted by THEPRFCT10 (Post 377155)
Thanks for that, quick questions: Car on or off, or just pull and reset?

Car off, and pull.

THEPRFCT10 03-22-2011 11:35 AM

Re: 430N (RHB) gives me the blank, then white SCREEN OF DEATH!...nothing works!
 
The fuse is not there and dealership just told me that the 430N RHB is BACKORDERED!!!! UUUUGGGGGHHHHH!


All times are GMT -5. The time now is 03:10 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community