Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems Discussion (http://www.jeepgarage.org/f77/)
-   -   05Wk Engine, Battery, and Airbag lights on/Egine wont start (http://www.jeepgarage.org/f77/05wk-engine-battery-and-airbag-lights-on-egine-wont-start-20414.html)

ShawtyKING 03-17-2011 10:02 PM

05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
I was trying to install a new head unit but it wouldnt power on so I then connected the factory head unit, which will no longer power on. My WK started fine until I checked to see if I had blown a fuse during installation. I removed all the interior fuses one by one and I dont think they were blown. I then checked under the hood and didnt see any issues either although I didnt remove more than two or three or those. I then went to start the WK again and the battery light began flashing then went solid. After that the airbag light also came on solid.

The engine light had been on before but I assumed that was because I swapped my old battery for a optima yellow top. Even with the optima batt, the WK still started and ran fine. ANY IDEAS??

robpp 03-17-2011 10:13 PM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
by chance did you remove a fuse in the uunderhood fuse box. the most forward one....that says SPARE inside the cover? its just a coomon mistake as its NOT a spare but something to do with the airbag light.

also i would check all the relays under the hood to make sure they are ALL SEATED nice.

ShawtyKING 03-17-2011 10:32 PM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
I will check again but thats pretty much what ive been doing for last couple of hours lol...i did pull the asd and hvac fuses but those should be in place...this hurts so bad...all I wanted was a new HU and my subs ready to go smh

Scottina06 03-17-2011 10:55 PM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
pull the negative terminal off thr battery and then step on the brake pedal a couple times and reconnect.

ShawtyKING 03-17-2011 11:16 PM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
Quote:

Originally Posted by Scottina06 (Post 378055)
pull the negative terminal off thr battery and then step on the brake pedal a couple times and reconnect.

I tried that holding the brake pedal down method a little while ago but I will try stepping on it instead, and I guess Ill try replacing as many fuses I can tomorrow morning. Thanks guys and any more tips would be GREATLY appreciated.

Scottina06 03-17-2011 11:30 PM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
you need to pull the codes

ShawtyKING 03-17-2011 11:44 PM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
where would i be able to get a code reader from?

Denny boy 03-17-2011 11:53 PM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
Is the battery dead?

Next step is to get codes. you can rent readers from most autoparts stores.

ShawtyKING 03-18-2011 12:00 AM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
Ill try and find one...Once i do that and i pull codes, I know that there are code list posted here but where would i go from there. I mean I know that I would match the codes and all but Im not super car savvy, especially since after all the research I did I thought this would be a simple install lol and I still failed hard. Once again thanks for all the suggestions and sorry for asking so many redundant questions.
*Edit* I got the same issue with two different batteries and Im sure they are not dead seeing as all the electronics I can think to check work. Headlights, HVAC, Outlets, Horn, etc.

ShawtyKING 03-18-2011 10:30 AM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
*Update* When I woke up this morning and turned the key to ON, the battery light is flashing again (it was on solid yesterday) and theres a clicking noise around where the ASD relay fuse is in the Power Distribution Center underhood.The car acts as if it wants to crank but it wont turn over. Any thoughts?

ShawtyKING 03-18-2011 12:27 PM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
I bought the code reader and not surprisingly it displays no codes

Scottina06 03-18-2011 12:38 PM

Re: 05Wk Engine, Battery, and Airbag lights on/Egine wont start
 
sorry...all you had to do was the key dance....turn the ignition on and off three times and after the third time....leave it on and if there are codes...it will dsiplay them.

So no codes...hmmm

sounds like you have a main relay not seated or you pulled of the main fuses and its not seated correctly. You couldve alos blown on of the main relays.

Go to your fuse boxes under the hood...thelong skinnny one. Check relay 33 and 35 and check fuses10,19, 20 and 24


All times are GMT -5. The time now is 10:20 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community