Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   does Check engine light turn on every 3 days for you? (http://www.jeepgarage.org/f5/does-check-engine-light-turn-on-every-3-days-for-you-20518.html)

Leonexx812 03-20-2011 01:06 PM

does Check engine light turn on every 3 days for you?
 
I recently bought an 08 5.7l GC limited and 2 days after driving it off the dealer ship lot the engine light went on.. i was like great.. took it to the dealership said it was an O2 sensor so they changed it... 3 days later it goes off again and now they changed the catalytic converter and the sensor again and another thing.. so 4 days go by and as i get on the highway yesterday the engine light goes off... so instead of going to run errands i rerouted right to the dealership flipped out on anyone i could so they gave me a new vehicle in the mean time a 2011 laredo until they find out whats wrong.... has this happened to anyone else?

White Chocolate 03-20-2011 04:48 PM

Re: does Check engine light turn on every 3 days for you?
 
Which codes are you getting exactly when the check engline comes on. Make sure you do the key dance to pull the codes so we know. Check engine light means alot of things.

http://www.youtube.com/watch?v=rD1SysWu_Fs

Walt 03-20-2011 05:22 PM

Re: does Check engine light turn on every 3 days for you?
 
Quote:

Originally Posted by Leonexx812 (Post 379395)
I recently bought an 08 5.7l GC limited and 2 days after driving it off the dealer ship lot the engine light went on.. i was like great.. took it to the dealership said it was an O2 sensor so they changed it... 3 days later it goes off again and now they changed the catalytic converter and the sensor again and another thing.. so 4 days go by and as i get on the highway yesterday the engine light goes off... so instead of going to run errands i rerouted right to the dealership flipped out on anyone i could so they gave me a new vehicle in the mean time a 2011 laredo until they find out whats wrong.... has this happened to anyone else?

Exactly the same scenario in last month with my '08 WK HEMI. Dealer changed out all 4 O2 sensors and both catalytic converters. Codes kept returning. Everyone at the dealer and Chrysler was baffled. They talked about wiring jumpers around the O2 sensors to the PCM (I wasn't happy).

You won't believe it, but I found a bad radiator cap. There was evidence of HOAT coolant around the filler neck and down the shock / spring area on the RHS. Replaced it and everything went back to normal. No codes in the last 3 days and MDS is now functional again. Will know for sure tomorrow when I make the 25 mile drive to work.

I've never heard of anything like this. Recommend the dealer pressure test your coolant system AND the radiator cap. This is an 18 psig system.

Hope yours turns out this simple in your new Jeep.


All times are GMT -5. The time now is 08:03 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community