Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Shipping protection residue ? And Amsoil (http://www.jeepgarage.org/f107/shipping-protection-residue-and-amsoil-21540.html)

vikingdave 04-09-2011 06:45 PM

Shipping protection residue ? And Amsoil
 
I just washed my new WK2 by hand for the first time. There seems to be some residue on top of the area near the clear guards by the back wheels. From the looks of it, maybe some of that white shipping film was not removed properly. It seems like I need some type of solvent to get this off, but I don't want to damage the clear plastic. Has anyone else seen this ? What can I use to safely remove it ? It's on both sides. Really glad I paid the "Dealer Fee" so they could do stuff like this, it was the dirtiest new car I have ever bought. Love the car, but the dealer was worthless in terms of prep. I also treated her to some Amsoil 5W20 XL last night, with their EAO filter after waiting about 3,000 miles for break-in. My brother has run Amsoil everywhere in his last two GC's and has now piled up about 350,000 mechanically trouble free miles between the two of them even with 10,000 mile oil change increments and the EAO filters, I intend to do the same.

Scottina06 04-09-2011 07:02 PM

Re: Shipping protection residue ? And Amsoil
 
goo gone should be safe to use....just be sure to rewax the area properly

vikingdave 04-09-2011 07:09 PM

Re: Shipping protection residue ? And Amsoil
 
1 Attachment(s)
I was worried about goo gone on the clear plastic patch, here's a pic ...

Scottina06 04-09-2011 07:13 PM

Re: Shipping protection residue ? And Amsoil
 
so they removed the protection film?

vikingdave 04-09-2011 08:35 PM

Re: Shipping protection residue ? And Amsoil
 
Quote:

Originally Posted by Scottina06 (Post 392862)
so they removed the protection film?

No, the film is still there but there is residue on top of it and around the area. Its' weird, it wont come off and it is just something on the surface of the clearcoat. I have seen some cars with white film glued on during shipping and was just wondering if that might be the cause, but maybe Jeep doesn't do that.

Scottina06 04-09-2011 10:48 PM

Re: Shipping protection residue ? And Amsoil
 
thats a static film that they use......it has no adhesive

ilber 04-10-2011 08:15 AM

Re: Shipping protection residue ? And Amsoil
 
good luck. I have slightly different opinion, don't get me wrong, I have about $3k worth of amsoil right now in my garage ( 2 x 55 gal 1x35 gal barrel), so i am a Amsoil fan-boy. However at 500 miles I am not swiching to amsoil yet. my plan on the third oil change which should put me just about 5k miles...
Amsoil is the crap, considering that if you buy in bulk it actually come as cheap as the cheapest moble1 one you can find ( wally world 5qt jugs). do you have a spec sheep for EAP filter? I am running wix or k&N oil filters, however if EAO is "better built" and price comperatevly- i will consider.
the worst part, I buy all that crap in bulk, i need to show maintn records. So now i have to do maintanance through the shop... oh well, i knew it when i got lifetime warr.


ilber


All times are GMT -5. The time now is 09:24 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community