Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Trouble Shooting/Problems/Service (http://www.jeepgarage.org/f107/)
-   -   Quadra Lift Problem?? (http://www.jeepgarage.org/f107/quadra-lift-problem-21651.html)

jp467 04-11-2011 06:55 PM

Quadra Lift Problem??
 
Well I have had Grand Cherokee #2 for two weeks it is a mid march build. So today I decide to try the qudra lift to see how it works. I press the up button with the vehicle in park it does go up but after several seconds I get a message " Air suspension requires imediate service/repair". After I get this message it won't do anything up or down until I shut I vehicle off and try again. I tried three different times one one it did go to off roadI without the message. The other times it went into fault. My question is what could be causing this and how easy to correct. In normal mode it seems fine and it does go into areo mode on the highway and back to normal no problem.

wjs81866 04-11-2011 07:55 PM

Re: Qudra Lift Problem??
 
There have been a few people (Myself included) that had an situation like yours, I took mine in. They checked everything out and cleared the code and I've never had another problem since. It seems like if anyone has had an issue it's been right away and that's been it.

jp467 04-11-2011 08:33 PM

Re: Qudra Lift Problem??
 
Quote:

Originally Posted by wjs81866 (Post 394099)
There have been a few people (Myself included) that had an situation like yours, I took mine in. They checked everything out and cleared the code and I've never had another problem since. It seems like if anyone has had an issue it's been right away and that's been it.


Was yours a problem going to off road 1 and 2? I hope it just a matter of clearing a code and not a leak in the system.

rich mac 04-11-2011 11:09 PM

Re: Qudra Lift Problem??
 
I had the same error message on two occasions before 500 miles. The first time the dealer cleared the codes and couldn't find a problem. The second time the dealer could find no active code. On mine, the problem seemed to happen when in normal drive mode or while going to park height. Since then I've had no messages and the QL system seems to be working fine. Here's to hoping that it's a break-in thing and the system settles down.

jp467 04-12-2011 08:41 AM

Re: Qudra Lift Problem??
 
I tried that QL again today and it did go to Off road 1, but when I went to off road 2 after several seconds the light kept flashing and I got the message about the air suspension needing service. When it does this I have to shut the vehicle off and restart to lower it. Anyone have any idea on this?

mjw930 04-12-2011 09:52 AM

Re: Qudra Lift Problem??
 
It's probably the controller module that's part of the pump/valve assembly, I've read about a few of those being replaced. Or it's low nitrogen which would indicate a leak. Either way, cycling the power or resetting a module isn't likely to fix it, it's going to require an actual mechanic to actually do some troubleshooting. This is not something you are going to get a simple fix for off an internet forum, that's what dealers and warranties are for.....

wjs81866 04-12-2011 10:20 AM

Re: Qudra Lift Problem??
 
Quote:

Originally Posted by jp467 (Post 394118)
Was yours a problem going to off road 1 and 2? I hope it just a matter of clearing a code and not a leak in the system.


Yes

It wouldn't go up, it would go down to park and back to normal but not any higher. Still drove the same, had I not tried to raise it I wouldn't have known there was a problem. The areo mode still functioned normally as well.

jp467 04-12-2011 12:03 PM

Re: Qudra Lift Problem??
 
Quote:

Originally Posted by mjw930 (Post 394370)
It's probably the controller module that's part of the pump/valve assembly, I've read about a few of those being replaced. Or it's low nitrogen which would indicate a leak. Either way, cycling the power or resetting a module isn't likely to fix it, it's going to require an actual mechanic to actually do some troubleshooting. This is not something you are going to get a simple fix for off an internet forum, that's what dealers and warranties are for.....


Yes I am taking it in next week. I just wanted to have an idea of what was going on with it. I have very litttle confidence in the dealer being able to troubleshoot it. When I talked to them of course I get the we have never heard of that problem. I made an appt next week when I can wait around while they check it out. After what I went through on my previous wk2 there is no way I am going to let them just tear it apart trying to correct a simple problem. I was thinking maybe it is just low on nitrogen from the factory since yesterday was the first time I tried it.

bobkbusch 04-12-2011 02:33 PM

Re: Quadra Lift Problem??
 
Just got the same message, "Air suspension requires imediate service/repair." I then tried to change the ride height and the EVIC said the "system is cooling down...please wait." Would not change ride height.

Going to the dealer tomorrow.... :mad:

faust 04-12-2011 03:44 PM

Re: Qudra Lift Problem??
 
I had the same problem, car had 100 miles on it. I took it to the dealer 3 times and they couldnt fix it until they figured it out, it was loose hose to the air suspension. over 1000 miles now with no further issues.

bobkbusch 04-12-2011 03:56 PM

Re: Qudra Lift Problem??
 
Thanks for that info. I will provide it to my dealer tomorrow. Did you also get a message that said "system is cooling down...please wait?"

jp467 04-12-2011 05:34 PM

Re: Qudra Lift Problem??
 
Mine seems to operate fine during normal operation. It's just when I try to go to Off road 1 or 2. It has made it into off road 1 a couple times but it will not go into off road 2. Then after several seconds of the light flashing I get the message Air suspension needs immediate service/repair. Mine is a recent build it was built in mid march so I would think the issues have been worked out.


All times are GMT -5. The time now is 10:52 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community