Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Technical Service Bulletins and Recalls (http://www.jeepgarage.org/f76/)
-   -   WK Hemi owners (http://www.jeepgarage.org/f76/wk-hemi-owners-22000.html)

NJwk5.7 04-19-2011 03:18 PM

WK Hemi owners
 
3 Attachment(s)
Hemi owners that are having transmission issues..... Keep your eyes peeled for a Service Bulletin or talk to your dealership/chrysler

Some of the issues i had:
-odd shift points
-RPMs stay the same with more gas
-very high RPMs and no shifting
-trouble accelerating & shifting from around 40mph
-check engine light sometime appears but not always
-ECO does not display...... when it should


i wish i knew more about what i was talking about but i dont...

Its basically some little metal piece (first up close pic) that gets warped and then breaks and causes havoc and creates metal shavings (last picture) but it only seems to be an issue with the Newest (last updated) WK 5.7L Hemi engines...

My Jeep has been in and out of the shop since 3/25 with the same issues and others...
The dealership/chrysler has now finally said that its something they have known about.....and now they will create a service bulletin about it...
I was also informed that a new transmission is on its way for my jeep......maybe if im lucky i will have it back by the weekend.......just shy of being a whole entire month!



DONT GET ME STARTED ABOUT THE LOANER CAR ISSUE...... WTF
(apparently i was VERY lucky to get a loaner cars for SOME of the time... and was SOMEwhat reimbursed for a truck i had to rent from enterprise...)

Walt 04-26-2011 11:08 AM

Re: WK Hemi owners
 
Quote:

Originally Posted by NJwk5.7 (Post 398872)
Hemi owners that are having transmission issues..... Keep your eyes peeled for a Service Bulletin or talk to your dealership/chrysler

Some of the issues i had:
-odd shift points
-RPMs stay the same with more gas
-very high RPMs and no shifting
-trouble accelerating & shifting from around 40mph
-check engine light sometime appears but not always
-ECO does not display...... when it should

Its basically some little metal piece (first up close pic) that gets warped and then breaks and causes havoc and creates metal shavings (last picture) but it only seems to be an issue with the Hemi engines...

My Jeep has been in and out of the shop since 3/25 with the same issues and others...
The dealership/chrysler has now finally said that its something they have known about.....and now they will create a service bulletin about it...
I was also informed that a new transmission is on its way for my jeep......maybe if im lucky i will have it back by the weekend.......just shy of being worked on for a whole entire month!

Thank you. If you are able to describe better what we're looking at in the 3rd frame, I would appreciate it.

I asked the Service Manager about it last evening. He was unaware of anything specific. I will provide him a copy of your post and pics, so he can investigate.

If yours gets fixed with a new part number, please retrieve and post it. Will make it that much easier for us to reference in our own demon-chasing process.

robpp 04-26-2011 11:32 AM

Re: WK Hemi owners
 
thanks.

the 4.7's have the EXACT same transmission so whatever it is would apply to hem as well.

ducks unlimited 05-01-2011 01:51 PM

Re: WK Hemi owners
 
what years does this apply to 05' and present?

blackpepper 05-01-2011 01:53 PM

Re: WK Hemi owners
 
I was also curious about the years.. b/c in 2009 they changed the HEMI engine (adding VCT) so that MAY have something to do with it.

Walt 05-02-2011 07:15 PM

Re: WK Hemi owners
 
Quote:

Originally Posted by NJwk5.7 (Post 398872)
Hemi owners that are having transmission issues..... Keep your eyes peeled for a Service Bulletin or talk to your dealership/chrysler.... Its basically some little metal piece (first up close pic) that gets warped and then breaks and causes havoc and creates metal shavings (last picture) but it only seems to be an issue with the Hemi engines...The dealership/chrysler has now finally said that its something they have known about.....and now they will create a service bulletin about it...

Gave a copy of your post (with color pictures) to the Service Manager today. He will ask Chrysler what is going on. He hadn't heard of anything in the works.
Anything more specific on part name or part no. that is failing?

Jahkneefive 05-13-2011 08:52 AM

Re: WK Hemi owners
 
I just did a quick hit search and didn't find anything, if you can give me your vin I can pull the STAR notes on the case and back into it that way. Whoever was asking on years affected, it shouldn't affect the 05s being as that we didn't have an eco light.

Chaoul1 05-13-2011 09:35 AM

Re: WK Hemi owners
 
Yes! Find out what years this will apply too! I have a feeling that my tranny is acting up sometimes!

ducks unlimited 08-15-2011 11:08 PM

Re: WK Hemi owners
 
My transmission is acting weird when i go from park to drive and from drive to reverse i get a loud clunk noise and it makes really worried about it.

Escape 08-16-2011 08:29 PM

Re: WK Hemi owners
 
Quote:

Originally Posted by ducks unlimited (Post 466670)
My transmission is acting weird when i go from park to drive and from drive to reverse i get a loud clunk noise and it makes really worried about it.

Check your front driveshaft for play.

Mine does the same thing. I think I hurt mine leaving the parking lot after seeing Fast and Furious Five. It was an epic exit though...:eek: It still works, just clunks now.

DaBigBone 08-16-2011 08:35 PM

Re: WK Hemi owners
 
Funny... my girlfriends 05 has been doing the exact same things you listed..

viking757 08-17-2011 12:25 AM

Re: WK Hemi owners
 
Quote:

Originally Posted by ducks unlimited (Post 466670)
My transmission is acting weird when i go from park to drive and from drive to reverse i get a loud clunk noise and it makes really worried about it.

More than likely it's your front axle isolator bushings.... Not tranny


All times are GMT -5. The time now is 07:25 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community