Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - ZJ (http://www.jeepgarage.org/f78/)
-   -   Strange Electrical Gremlins (http://www.jeepgarage.org/f78/strange-electrical-gremlins-22514.html)

BLACK DOG 04-29-2011 05:03 AM

Strange Electrical Gremlins
 
I have been having some weird elect. problems with a couple of my ZJs , the blower fan keeps running with ign. off, intermittent on 1 5,2 and always on my 5.9 ( I have to pull the fuse to stop it )
I also see the 4wheel indicator shows 2 rear or 2 front or all 4 at different times restart the car and it may change haven't noticed it change without restart, could this be just dirty connections ??
not looking forward to pulling the dashes apart, any answers similar problems brothers and sisters, it's keeping me up late :confused:

Frango100 05-29-2011 02:25 PM

Re: Strange Electrical Gremlins
 
He Bob, did you find the problem? Did it had to do with the ignition switch?

BLACK DOG 05-29-2011 04:19 PM

Re: Strange Electrical Gremlins
 
No Frank, problems not corrected, I haven't had time to get to it...I'm convinced the problem is dirt/dust in the connections, I'm having similar problems with bulbs not lighting, I check the bulb, it looks ok I plug it back in and it works fine. There is a lot of dust in my area and dampness too. I have been doing mods on the 5.7 WK and training my dog. Just not finding any time (always something more important to do) Bob.

Frango100 06-02-2011 07:50 AM

Re: Strange Electrical Gremlins
 
Dust normally shouldn´t do much harm, most of the time the problem is moisture which causes the contacts to oxydice and create a certain resistance. But in your case with the fan the problem is probably different, you have power when youre not suppost to have it. I think that only the ignition switch is there to cut the power to the blower fan.

BLACK DOG 06-02-2011 10:24 AM

Re: Strange Electrical Gremlins
 
the ign. switch could be the problem, another thing is both jeeps I'm having this issue with have other things added to the system that could be contributing to the problem, (aftermarket alarm on one and a stereo on the other, both have bypassed ignition and have power with ign. switch off) I'm not very good with solving elect. problems unless it is an obvious problem like a broken wire, I start swapping parts / switches to find the problem...ign. switch seems like a good place to start. Looking to see if extra wires were tapped into it for example. Both Fans also stay running even with the heater switch in the off position.

Frango100 06-02-2011 08:04 PM

Re: Strange Electrical Gremlins
 
If you have an electrical schematic, you could see which wire from the ignition switch is going to the blower motor. Then you could measure for voltage with the switch in off. I think its better to troubleshoot this first before trowing parts to it in the hope to solve it.
I won´t expect a radio or alarm bypass wire would cause this problem, because they normally have a low Amp fuse in line and that one would probably blow by the high blower current. You also said that pulling the blower motor fuse will stop it, so its then almost certain that the problem is in the blower motor circuit itself, or better, the ignition switch is not cutting the power.

BLACK DOG 06-03-2011 05:14 AM

Re: Strange Electrical Gremlins
 
I will check out the ign. switch, I have a schematic and meter. Hopefully it will save me from having to remove the heater control, the niner has a stereo poorly installed (loose wires etc.) Powered direct to the Bat. possibly draining the battery as well.Though not as much of a drain as the blower fan. ( the niner has the 40 amp fuse removed)


All times are GMT -5. The time now is 07:11 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community