Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Troubleshooting/Problems (http://www.jeepgarage.org/f203/)
-   -   Tranny isn't shifting properly (http://www.jeepgarage.org/f203/tranny-isnt-shifting-properly-22573.html)

dennk 04-30-2011 03:45 PM

Tranny isn't shifting properly
 
Hi, New member here and I'm having a problem. I have a 2002 Grand Cherokee with a 4.7 V8 and 130.000 miles on it. It has a 4 speed with OD tranny and is a select a trac 4 WD. Truck has an issue with transmission. When my speed is between 50 and 55 MPH tranny shifts into OD then drops down to 4th and then shifts back to OD and again to 4th.This happens alot at a steady speed, also there are times at 60mph the truck tacs at 2000 rpm .This is a 70mph speed not 60mph. I had the fluid changed, filters ,etc. Can't seem to find any problems, but I'm not happy with this issue.And a new tranny is alot of cash. Also when its below 30 degrees Far. The tranny won't shift into 4th or OD till it totally heats up ...........HELP.................................

Frango100 04-30-2011 04:51 PM

Re: Tranny isn't shifting properly
 
I would put it on a DRB scanner first to check for fault codes. But this problem seems to be speed sensor related. You could check the input/output speed sensor connectors and clean them with contact cleaner.

dennk 04-30-2011 06:56 PM

Re: Tranny isn't shifting properly
 
I did forget to mention there are no fault codes


All times are GMT -5. The time now is 09:38 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community