Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK (http://www.jeepgarage.org/f5/)
-   -   07 5.7 Hemi misses under load (http://www.jeepgarage.org/f5/07-5-7-hemi-misses-under-load-22615.html)

woodywoo 05-01-2011 02:39 PM

07 5.7 Hemi misses under load
 
I recently purchased an Off Lease, 07 GC Limited, 5.7 hemi with 45k miles on it. It feels to me to be missing when I slowly accelerate from about 40 mph. If I keep pushing on the accelerator it will eventually down shift and the miss disappears. Do these lease vehicles get all of the maintenance performed on them that is listed in the owners manual? I read where the plugs should have been replaced at 30K miles. Dooes anyone have any experience with this problem, I really appreciate a little advice. Thanks

Escape 05-01-2011 10:26 PM

Re: 07 5.7 Hemi misses under load
 
Check the plugs and replace/regap to factory specs and since it is a off lease vehicle they should have all records. If in doubt that the maintenance was done properly you can always do it again.

dmsfun 05-02-2011 07:36 AM

Re: 07 5.7 Hemi misses under load
 
You may be feeling the MDS activating, which shuts down 4 cylinders when you accellerate slowly. If this miss you are feeling does not happen while accellerating more briskly, this is probably it.

woodywoo 05-05-2011 07:12 PM

Re: 07 5.7 Hemi misses under load
 
This is the first time I have had a jeep equipped with this feature, maybe what i am feeling is a normal thing. I purchased the plugs today and may get to put them in on Sunday afternoon. I had planned to replace them just in case they were not replaced under lease maintenance. I'm happy with the way it runs otherwise.

Thanks for you input.


All times are GMT -5. The time now is 06:59 PM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community