Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Interior/Exterior/Visual (http://www.jeepgarage.org/f197/)
-   -   Help with HID capsule/ballasts (http://www.jeepgarage.org/f197/help-with-hid-capsule-ballasts-22867.html)

Amelie 05-06-2011 10:12 PM

Help with HID capsule/ballasts
 
So I was driving tonight and my HID's in the low's go out. I wait a little bit with them turned off and try to reignite them but to no success. My current setup is a kit from DDM, 55w x 4500k. I have them hooked to a relay which are bolted onto the battery terminals and sometimes have had connection issures where it wouldn't get power and they would shut off but I've fixed that already.

I'm thinking my capsules died, in the last few weeks I've noticed upon start up that it would flash a pink color for like a second while warming up. I think the ballasts are still fine. Any suggestions?

CPT2010 05-06-2011 10:39 PM

Re: Help with HID capsule/ballasts
 
test the fog bulbs to see..
cancels out other possibilities and holla back

Amelie 05-06-2011 10:44 PM

Re: Help with HID capsule/ballasts
 
1) Why the fogs? They're not HID.

2) The fogs are working fine

CPT2010 05-06-2011 10:48 PM

Re: Help with HID capsule/ballasts
 
you have any other hid bulbs?
i said fogs bc i was hoping they were hid too and you you switch them out to see if they fire up on your low beam ballast and see if its a short or anything

Amelie 05-06-2011 10:50 PM

Re: Help with HID capsule/ballasts
 
Yeah, When I first bought the kits from DDM I ordered 2 x Relays, and 4 x 55w Ballasts, 1 Ballast went bad when I first got it and blew 2 bulbs that were intended for the fogs lol. I have an extra set of 4500k on hand.

CPT2010 05-06-2011 10:54 PM

Re: Help with HID capsule/ballasts
 
if you know you have good bulbs try it out on the ballast. odd for both ballast to go out. maybe its the connection. or the bulbs.
best thing to do is slowly narrowing down the easy things

Amelie 05-06-2011 10:56 PM

Re: Help with HID capsule/ballasts
 
I'm going to take them out tomorrow it check the capsules. When my first 2 went out due to the bad ballast it looked like the salts inside had crystallized. The glass was metallic gray covered so hopefully that might be the problem.

CPT2010 05-06-2011 11:12 PM

Re: Help with HID capsule/ballasts
 
lemme know man. hopefully easy fix

Amelie 05-07-2011 07:50 AM

Re: Help with HID capsule/ballasts
 
Alright so I was out there checking it for about 2 hours. I figured maybe giving it a night they would work...wrong lol. I took out both capsules and they indeed had the grayish crystallization on the inside like my initial blown bulbs. So I swapped them both out with my new 4500k capsules and still to no avail they would not ignite. I swapped in a new ballast on each side (No luck) it wasn't the ballasts, so I figured it had to be the relay.

I was in the process of swapping out my current relay for the new one when my ground terminal bolt sheered off due to corrosion lol. On the main relay piece it has some rust on it so I think that's my overall problem.

1) Are the battery connectors hard to replace? They're both pretty heavily corroded.

2) would I get better conductivity replacing them? I'm positive they've been on since the factory so I think it should help alot

Thanks for the help :)

CPT2010 05-07-2011 12:02 PM

Re: Help with HID capsule/ballasts
 
yea cut the connectors of and re strip a piece of wire at the end and crimp a new connector on.

in all honesty if you have the time today, take it all of a restart so you can make sure everything works before you put it all back together

Amelie 05-07-2011 06:21 PM

Re: Help with HID capsule/ballasts
 
Man this is really pi$$ing me off. I got a new bolt for the terminal, plugged in a whole new relay and replaced the capsules and it still doesn't work. It's like I'm not getting power from the battery through the relay cables. I am contemplating hooking it up without the relay but I'm worried it will damage the Jeep.

Update: I've tried doing away with the relay and hooking it up to the stock harness and they still won't fire, I wonder if my ballasts are bad. I don't know what to do. Everything worked fine 2 days ago.

straty1987 05-07-2011 10:34 PM

Re: Help with HID capsule/ballasts
 
you can run the HID with out the harness.
the relay or fuse on the harness line might be bad.

if the bulbs are blown there blown. and you cant test teh blaster.

if the original 9006 bulbs are working might be teh entier hid setup is bad.
DDM has been having a higher fail rating.

if your cables/batter are corroted the corrosion can stop tehg connection form happing and HIDS dost like to loss power or double start ups.

clean off you battery and terminal with the water/backing soda or a can of coke. tones of you tube videos
get new bolts and nuts i believe there 1/4 x1 in (i bought longer ones for my added connection on teh positive)
they sell battery fabric rings that help stop corrosion and a battery lube. they help
also don't forget to clean inside the terminal bolt hole
i know its not fun but the corrosion dose not go away


All times are GMT -5. The time now is 06:05 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community