Jeep Garage  - Jeep Forum

Jeep Garage - Jeep Forum (http://www.jeepgarage.org/forums.php)
-   Grand Cherokee - WK2 - (http://www.jeepgarage.org/f73/)
-   -   6 month anniversary! (http://www.jeepgarage.org/f73/6-month-anniversary-23970.html)

JohnS 06-03-2011 01:33 PM

6 month anniversary!
 
Wow, it's been 6 months today, since I picked up my GC. :eek:

6 months of rattle & trouble free driving, too.:thumbsup: The GC has only been back to the dealer once .... for an oil change to synthetic oil. The Jeep as seen 2 major snow storms, sub-zero temperatures and now 80 degree summer heat.

There have been a few minor one shot gremlin occurrences - 1) the tailgate opened on it's own, 2) the engine started by itself, and 3) the theft alarm went off for no reason. 1 & 2 were probably caused by the key fob tight pant syndrome, while #3 is still unexplained. I also found a wire harness located too close to the exhaust, but it was easy to relocate. So far these issues have only occurred once so, fingers crossed, hopefully they won't happen again.

It's been an enjoyable 6 months and I have nothing be good things to say about quality, fit, finish, and overall ride quality of the WK2. Not bad for a first year model.;)

Here's to another 6 months of trouble free driving.:w00t:

Red G8R 06-03-2011 01:50 PM

Re: 6 month anniversary!
 
Good news John.

It's been 8 months for me. The only repair was a loose driver's visor which was repaired at the dealer. Otherwise, so good so far. I too have had the alarm go off x 2 for no obvious reason. I did have the engine start while I was chaning my wheels for winter and the alarm went off at a parking garage as I leaned out the window but both of these were due to the fob in the pant syndrome.

Overall, I'm very pleased with my 4th GC.

JoeSchmoe007 06-03-2011 02:05 PM

Re: 6 month anniversary!
 
Quote:

Originally Posted by Red G8R (Post 424457)
Good news John.

It's been 8 months for me. The only repair was a loose driver's visor which was repaired at the dealer...

How did this get fixed? There is a thread about it (I assume you had the same problem):

http://www.jeepgarage.org/f107/sun-visor-retention-clip-very-loose-23711.html

chibianh 06-03-2011 02:33 PM

Re: 6 month anniversary!
 
good to hear! 8 months here as well. Got mine back in Sept and only had one major repair (compressor replacement). Other than that, everything is swell and I would like to think that I beat mine up more than most WK2 owners out there. No regrets purchasing it and I would do it all over again if given the chance :)

Red G8R 06-03-2011 02:40 PM

Re: 6 month anniversary!
 
Quote:

Originally Posted by JoeSchmoe007 (Post 424467)
How did this get fixed? There is a thread about it (I assume you had the same problem):

http://www.jeepgarage.org/showthread.php?t=23711

I didn't know about this thread.

My visor detatched at the hinged side and a part had to be ordered for the repair. Since then, it has been perfect.

IndyBob 06-03-2011 03:01 PM

Re: 6 month anniversary!
 
Seven months for me. No real problems at all The real test will be in 2 weeks when I head out to Moab from Indianapolis. About a 3300 mile trip as well as some fun (I hope) off road stuff.

1200RT-P 06-03-2011 03:10 PM

Re: 6 month anniversary!
 
Quote:

Originally Posted by Red G8R (Post 424494)
I didn't know about this thread.

My visor detatched at the hinged side and a part had to be ordered for the repair. Since then, it has been perfect.

doesn't sound like the same issue we're having. I got excited for a fix for a minute. :(

Cherodude 06-03-2011 03:29 PM

Re: 6 month anniversary!
 
I'm also at exactly 6 months today, 21,500 kms. Totally pleased with this ride. The engine/transmission TSBs made it even more of a joy to drive. Only two non-maintenance issues: rear chrome lock button stopped working and the iPod port in the armrest had to be repaired. Both done under warranty and working well months later.

Well done Jeep!

JoeSchmoe007 06-03-2011 03:58 PM

Re: 6 month anniversary!
 
Quote:

Originally Posted by Red G8R (Post 424494)
I didn't know about this thread.

My visor detatched at the hinged side and a part had to be ordered for the repair. Since then, it has been perfect.

Yours seem to be a different issue

netcoolery 06-03-2011 06:42 PM

Re: 6 month anniversary!
 
Quote:

Originally Posted by IndyBob (Post 424509)
Seven months for me. No real problems at all The real test will be in 2 weeks when I head out to Moab from Indianapolis. About a 3300 mile trip as well as some fun (I hope) off road stuff.

We'll look forward to some pics and a trip story on that. I'm curious ... are you going to take the front air dam off?

moosehead 06-03-2011 09:47 PM

Re: 6 month anniversary!
 
thumbsup here as well after deep snow, subzero winter, mild trail, 4500 lb boat tows.

only complaints are speeding ticket and mod fever.

IndyBob 06-05-2011 10:38 AM

Re: 6 month anniversary!
 
Quote:

Originally Posted by netcoolery (Post 424599)
We'll look forward to some pics and a trip story on that. I'm curious ... are you going to take the front air dam off?

I would like to but I haven't had the nerve to do it yet. I am sure it will come off but getting it back on for the trip home is what worries me. I may try again and do a test run this week before I leave. I tried once before but chickened out. Got off all seven of the quick disconnects but I then stopped when I wasn't sure actual how to do it.:confused:


All times are GMT -5. The time now is 05:55 AM.

Powered by vBulletin® Version 3.8.8 Beta 4
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
Copyright 2012 - JeepGarage.Org
The Jeep Grand Cherokee Owners Community